[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Help, I've installed RHEL5 and tried to create one dom and all of the defaults are not working


I’m trying to learn about XEN and am having problems …. here is what I did ..


I installed RHEL 5

            Linux version 2.6.18-8.1.1.el5xen (brewbuilder@xxxxxxxxxxxxxxxxxxxxxxxxxxxx) (gcc version 4.1.1 20070105 (Red Hat 4.1.1-52)) #1 SMP Mon Feb 26 20:51:53 EST 2007


I updated all of the RPMs

# yum update

… stuff …

No Packages marked for Update/Obsoletion


I updated the /etc/xen/xmexample into a new file dom1

#  -*- mode: python; -*-

kernel = "/boot/vmlinuz-2.6.18-8.1.1.el5xen"

memory = 64

name = "dom1"

vif = [ '' ]

disk = [ 'phy:hda1,hda1,w' ]

root = "/dev/hda1 ro"

extra = "4"


I updated the DevController.py script for the 3 argument problem that I got the first time I ran xm create

# xm create dom1 -c

Using config file "./dom1".

Error: destroyDevice() takes exactly 3 arguments (2 given)


And am now up to the following error

# xm create dom1 -c

Using config file "./dom1".

Error: Device 769 (vbd) could not be connected. Hotplug scripts not working.


Any suggestions, any and all help will be welcome.






Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.