[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] mount: could not find filesystem '/dev/root'

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Prabhakar Chaganti" <pchaganti@xxxxxxxxx>
  • Date: Sun, 8 Apr 2007 08:44:42 -0400
  • Delivery-date: Sun, 08 Apr 2007 05:44:02 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=BLCc1R/01LljOE6Z8Xnl9i+X/8czAKzOTRBSt1vOoWDHIrgwvIS9F/b8TbBYczzHnqTJHU3Gpaw+4bm704Aax29Elgzamzj1KEB/oQdwRWM1/Os25YGNFcZPLiUJlEyckQj9wdoPtKs+5A6Dwv6mEy8dVPQxwAq/Jb9VwJUjAFE=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Can you please post your grub.conf section for this kernel? I think the initrd you are specifying in your grub.conf doesnt have the drivers to mount your root fs. Try creating the mkinitrd the README way, except dont put the aacraid part in the command.


On 4/7/07, Ismael Hasan Romero <kraziest@xxxxxxxxx> wrote:
Hi there. I got a kernel panic caused by <mount: could not find
filesystem '/dev/root'> when I tried to install xen from the sources
(to compile modules on my own).

Now I have installed in my system Fedora Core 5 the following kernels:

2.6.20-1 xen0
2.6.16 xen
2.6.18-1 xen0

All of the kernels run ok except the 2.6.16 xen kernel, it causes the
kernel panic on boot. I downloaded this from the repositories in
http://xenbits.xensource.com/, the xen-3.0.3-testing.hg; I used
mercurial to get a copy.

I followed the Readme so I did

make world
make install

Then I had in my /boot what we ned to boot except the initrd. I made
it twice and none of them worked:

-mkinitrd -v -f --with=aacraid --with=sd_mod --with=scsi_mod
initrd-      -> that's the Readme way
-mkinitrd initrd-       -> when the
Readme didn't work

I have no idea what the problem can be, if something similar occured
to anyone or anyone can give me a light about this problem it would be
a great help.

If someone needs more details about my configuration or else just ask me please.

One last thing, before the kernel panic occurs a warning appears. This
is about "unsupported acesses", it sais that there is a problem with
the /lib/tls and that because of this the system may run slow. If
someone believe that this is important I can copy here the exact

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.