[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] mount: could not find filesystem '/dev/root'

  • To: "Jerry Amundson" <jamundso@xxxxxxxxx>
  • From: Ismael <kraziest@xxxxxxxxx>
  • Date: Sun, 8 Apr 2007 18:01:07 +0200
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Sun, 08 Apr 2007 09:00:00 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=o4yjHQyX+neB1U5E2B2RgGTduGn6EizD1lVMUvXBgqNUQJwIMCrQBnFOPrCmgz3p3UtMEeJhZPWtgQDp/QaXg4YNaEQ0BSD5Zx4OfZhMkp80LTMxtH9VHJ3plUJ3x2nV5L3JUSo8c1OUKCuLkOwpBImTVsSfmPrY3BnDRij2bgQ=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I tried also installing the xen3.0.4, the 3.0.4 dom0 and the 3.0.3
dom0. With both dom0 it can start, but it cannot run the graphical
mode and in the logs appears a "failed to initialize core devices", so
I'm begining to think that I can have a wrong .config. Any suggestion
is well received.

On 4/8/07, Jerry Amundson <jamundso@xxxxxxxxx> wrote:
On 4/7/07, Ismael Hasan Romero <kraziest@xxxxxxxxx> wrote:
> Hi there. I got a kernel panic caused by <mount: could not find
> filesystem '/dev/root'> when I tried to install xen from the sources
> (to compile modules on my own).

The key error is probably in the drivers loaded prior to the above message...
I searched and before the /dev/root problem happens a cannot load lib/sd_mod.ko

> -mkinitrd -v -f --with=aacraid --with=sd_mod --with=scsi_mod
> initrd-      -> that's the Readme way

On a whim, try "--preload=aacraid"?
Is aacraid the scsi_hostadapter in /etc/modules.conf, and used by the
other /etc/grub.conf sections that work correctly?

I tried this (--preload) but it doesn't change the problem. I have no

> One last thing, before the kernel panic occurs a warning appears. This
> is about "unsupported acesses", it sais that there is a problem with
> the /lib/tls and that because of this the system may run slow. If
> someone believe that this is important I can copy here the exact
> message.

Hmm, that's "normal", but usually independent of the filesystem error.
That may play in, though, as you've compiled from source? I'm not
I did what the warning says (mv /lib/tsl) and the warning still appears.


"Oh joy! Rapture! I've got a brain"

Thanks for answering

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.