[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] mount: could not find filesystem '/dev/root'

  • To: Ismael <kraziest@xxxxxxxxx>
  • From: "Jerry Amundson" <jamundso@xxxxxxxxx>
  • Date: Sun, 8 Apr 2007 13:28:02 -0500
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Sun, 08 Apr 2007 11:27:01 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=uj38AdD3dmpdXNOmGmZ+dx52q68uw+7PkvYU45DNjt/3EQ7zsJMmEnolM/sPGp7ASXkcwEnETYnaFhhhTEBep5dk+kSZztQEWp2rVAaY38wXzdLlyJn8NBpYHNkyCUBOWHISTsp1/ufKLMKPl+3mRqf7bQWmn7j6AdfYi6AKu8A=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On 4/8/07, Ismael <kraziest@xxxxxxxxx> wrote:
I tried also installing the xen3.0.4, the 3.0.4 dom0 and the 3.0.3
dom0. With both dom0 it can start, but it cannot run the graphical
mode and in the logs appears a "failed to initialize core devices", so
I'm begining to think that I can have a wrong .config. Any suggestion
is well received.

Ok, maybe one problem is your question...

Generally, there are four (4) options for you , yet you seem to have
done about seven (7) different things. :-)

> The key error is probably in the drivers loaded prior to the above message...
I searched and before the /dev/root problem happens a cannot load lib/sd_mod.ko

Well, you think that might be a problem? (hint: answer "yes, that
would be a problem")

> On a whim, try "--preload=aacraid"?
> Is aacraid the scsi_hostadapter in /etc/modules.conf, and used by the
> other /etc/grub.conf sections that work correctly?
I tried this (--preload) but it doesn't change the problem. I have no

What of, do you "have no"?

I did what the warning says (mv /lib/tsl) and the warning still appears.

Then you didn't do what the warning says.

Back to your four (4) options:
1. Xen and kernel from Fedora
2. Xen and kernel from XenSource
3. Stable source
4. Unstable source

I all cases, the initrd image needs to work with your hardware.
Maybe start from the beginning with 1. - and "yum update", as none of
the grub entries above are even current.


"Oh joy! Rapture! I've got a brain"

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.