[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] mount: could not find filesystem '/dev/root'

  • To: "Jerry Amundson" <jamundso@xxxxxxxxx>
  • From: Ismael <kraziest@xxxxxxxxx>
  • Date: Sun, 8 Apr 2007 22:23:51 +0200
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Sun, 08 Apr 2007 13:22:46 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=KSUl7wRASif9nJGn/dA+NHgvY9t+vvUTSfgjIPZEohjrIkzBt4KmvD1XWzKC5QF5q49PGzLI8+yhnJxZFqlkFe4LlV4MEl3gwfqQYGjZSMiSBhk749TfXOn74GTzK75AQyQVE0e87wtF0HVoYsGkcOcVCpjGJNdxy7oDSIU92Hc=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On 4/8/07, Jerry Amundson <jamundso@xxxxxxxxx> wrote:
On 4/8/07, Ismael <kraziest@xxxxxxxxx> wrote:
> I tried also installing the xen3.0.4, the 3.0.4 dom0 and the 3.0.3
> dom0. With both dom0 it can start, but it cannot run the graphical
> mode and in the logs appears a "failed to initialize core devices", so
> I'm begining to think that I can have a wrong .config. Any suggestion
> is well received.

Ok, maybe one problem is your question...

Generally, there are four (4) options for you , yet you seem to have
done about seven (7) different things. :-)

> > The key error is probably in the drivers loaded prior to the above 
> I searched and before the /dev/root problem happens a cannot load 

Well, you think that might be a problem? (hint: answer "yes, that
would be a problem")

I was surprised when I saw it, I didn't remember seeing it the first
time. Another person answered here that when making the initrd image I
just try to ignore the aacraid option; so I was making the latest init
images with this:

mkinitrd -v -f --with=sd_mod --with=scsi_mod

instead of :
mkinitrd -v -f --with=aacraid --with=sd_mod --with=scsi_mod

When I use mkinitrd just as the readme says (the second way) there is
no error loading lib/sd_mod.ko

> > On a whim, try "--preload=aacraid"?
> > Is aacraid the scsi_hostadapter in /etc/modules.conf, and used by the
> > other /etc/grub.conf sections that work correctly?
> >
> I tried this (--preload) but it doesn't change the problem. I have no

What of, do you "have no"?

I eat some words here, I don't know why. I have no a /etc/modules.conf archive.

> I did what the warning says (mv /lib/tsl) and the warning still appears.

Then you didn't do what the warning says.

I eat words again here, sorry. I did <mv /lib/tsl /lib/tsl.disabled>.

Back to your four (4) options:
1. Xen and kernel from Fedora
2. Xen and kernel from XenSource
3. Stable source
4. Unstable source

I all cases, the initrd image needs to work with your hardware.
Maybe start from the beginning with 1. - and "yum update", as none of
the grub entries above are even current.


I tried to download Xen sources from Fedora page but I didn't find it,
so I'll use the second option
"Oh joy! Rapture! I've got a brain"

thanks for answering

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.