[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] network error, even when reboot into non-Xen smp kernel

  • To: Robert Ficcaglia <rficcaglia@xxxxxxxxx>
  • From: Nico Kadel-Garcia <nkadel@xxxxxxxxx>
  • Date: Mon, 09 Apr 2007 10:59:36 +0100
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 09 Apr 2007 02:57:05 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:user-agent:mime-version:to:cc:subject:references:in-reply-to:content-type:content-transfer-encoding; b=aDLN+huhyi8s4x6zZyHXcTAY206GkBL5OZNkG7DB7EbJA3QL6zLZSNAwweST7F0BeMaVr+A5gQsSwXuaeeNIvTilJ/sS7NHWSzCWjAeGQWvG8Alu0gdFGmlh0Y96l+r9xoczxkr634WMmgaaWpAzBfLv/mCpF9PtzWXJMBZDhX0=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Robert Ficcaglia wrote:
After installing xen-3.0.4_1-install-x86_32p.tgz on a CentOS 4.4, I was getting a network error:
Device eth0 has different MAC address than expected
First, why aren't you using the RHEL 4 RPM? It's true they accidentally left out the documentaiton in that, but it works fine, and has RPM kernels for both Dom0 and DomU.

Second, unless you hard-code your MAC address in your Xen configuration file, it's going to get changed randomly in your DomU's every freaking time you reboot them. And RedHat's network setup tools look in /etc/sysconfig/network-scripts/ifcfg-eth* to associate the HWADDR setting with specific network devices. This keeps eth0 and eth1 from getting swapped around for different kernel configurations, and helps keep the network device names consistent when adding wi-fi or USB network devices.

You can also simply comment out the HWADDR lines in /etc/sysconfig/networ-kscripts/ifcfg-eth* if you have only one network device and thus aren't worried about swapping them.

Is the problem in your Dom0? Do you have multiple network devices?

I have searched for hours here and other places, tried all the recommended solutions and no luck. However, my real question is this... Even after I reboot into the previous CentOS kernel ( CentOS (2.6.9-42.0.10.ELsmp )), I get the same network error. I have tried this on 2 different boxes and it is completely reporducible. (Different network cards, too.) Strangely, I can boot into the non-smp kernel: CentOS (2.6.9-42.0.10.EL) and get networking.
See above.

What is Xen doing that is persistent and causing network failure even after fallback to the original smp kernel?? (Maybe it is worth saying that the network was 100% fine before Xen install, in fact, sadly it is a completely remote server, so that is the only way to get into the box unless I want to pay for an expensive remote hands service!!)

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.