[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] network error, even when reboot into non-Xen smp kernel

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Robert Ficcaglia" <rficcaglia@xxxxxxxxx>
  • Date: Sat, 7 Apr 2007 00:53:47 -0700
  • Delivery-date: Mon, 09 Apr 2007 02:47:22 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type; b=eIYaJ5DcCMshbN+tRbtDa/a1UrStja22Ap+e9nwmVeWQiDcxXQyJtTYX3YvHtv7jSXaTe53KEVSYZRHF4+ewWn3FiZjmCqj56OI5k4bV/BdqGaGgkvI5fzmkolRKFqSgwNjjjlkOASftE+xctpGPs0WkJmyhGeLSFcCMEQfBN2Y=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

After installing xen-3.0.4_1-install-x86_32p.tgz on a CentOS 4.4, I was getting a network error:
Device eth0 has different MAC address than expected
I have searched for hours here and other places, tried all the recommended solutions and no luck. However, my real question is this... Even after I reboot into the previous CentOS kernel ( CentOS (2.6.9-42.0.10.ELsmp )), I get the same network error. I have tried this on 2 different boxes and it is completely reporducible. (Different network cards, too.)
Strangely, I can boot into the non-smp kernel: CentOS (2.6.9-42.0.10.EL) and get networking.
What is Xen doing that is persistent and causing network failure even after fallback to the original smp kernel?? (Maybe it is worth saying that the network was 100% fine before Xen install, in fact, sadly it is a completely remote server, so that is the only way to get into the box unless I want to pay for an expensive remote hands service!!)
How can I undo these changes and restore networking to my smp kernel? Help please!!
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.