[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] PV drivers for HVM legacy Linux guests

  • To: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Alexander Dubinin" <adubinin@xxxxxxxxx>
  • Date: Sat, 14 Apr 2007 01:06:15 -0700
  • Delivery-date: Sat, 14 Apr 2007 01:05:02 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=lyV/cga0iKYgijXBG97bSRFVKRfnT4ICjCiamQq9zaungjopREUd0ai/jtfdD1Z5MvUha6Gj1SLNcUnfcu5UhuvxmBj5Gdcqtm7NZ97gTxk81cjreqokpUWTv4HgClA9Qt8zBZzeCD1tGYDlGw2+U8XRiThTrGaVmHh2psn2jQ8=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi all,

I've found some talks in this maillist that "ioemu is deprecated" and
"use PV drivers"...
Unfortunately, I've not been able to find any hint in documentation
how to do it for Linux.
Googling also not gives any usable results, but ADs of commercial
solutions like VI/XenSource or just blogs with rumors how good PV
drivers are...

And ioemu is still in all docs as the only HVM way to access disk/network...

Does anybody have a hint - how to make HVM paravirtualized drivers working?

I've tried these from latest XEN sources (from "unmodified_driver") on
SLES10, but they have not able to keep system alive more than 3-5
minutes (It have enough time to boot and get IP address from DHCP,
connect to NIS/KDC, but then hangs).

Also, even then "ioemu" option is not used, device emulation is still
working for HVM domains.
Is it possible, that this causing conflicts with blk/net-front drivers
and resulted hang?
How to _really_ disable ioemu, and how to avoid problems with legacy
tools (like boot loaders) support in this case? Is XEN BIOS image
working through hypercalls to access block devices directly and
implement int13? Or it's still same crapy BIOS image from QEMU?

Anyway, I don't need to use SLES10 in that way, as it have PV mode
working good enough with same kernel...

Real need is to run SLES9 SP3 in HVM mode with PV drivers.

So far I've not been able to compile these even for latest SLES9
kernel (Which is quite old - 2.6.5-xxx).
It's not possible to use SLES9 in para-virtualized mode - as it
requires much newer kernel to be installed, which is not acceptable...

Versons of XEN tried:
3.0.4 from xensource, from Novell forge (of April 4-th)

Any thoughts, hints or ideas?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.