[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] dom0 can't boot by nfsroot?

Hi, everyone, please help.
I'm desperate now because of this problem.
What I want is to boot xen dom0 through nfsroot.
I configured "root file system on NFS" and make all modules"build-in" by set 
"loadable modules" disable  when compiling linux-...-xen kernel, then I 
designated grub parameters as:

title xen remote
kernel xen.gz dom0_mem=256000
module vmlinuz root=/dev/nfs nfsroot= 

then there occured NFS getport error, and kernel panic.

That's weired for I had tested NFS server by nfsroot a normal Linux just 
before. So I booted again and tcpdump the eth0 of the nfs server. I found there 
was no
nfs packet received at all!
The most possibility is there's no network device working, but I did choose the 
my Intel PRO/100+ driver when compiling the kernel. 
I tried  "loadable modules" and using initrd then , still no working. Anyone 
can save me?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.