[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] dom0 can't boot by nfsroot?

It turns out that I made a beginner mistake:
I used 'make world' to build . It just overwrote my .config file everytime
by copying default xen-3XXX/disk/install/boot/config-2.6.XX.XX-xen.

xuguangbin wrote:
> Hi, everyone, please help.
> I'm desperate now because of this problem.
> What I want is to boot xen dom0 through nfsroot.
> I configured "root file system on NFS" and make all modules"build-in" by
> set "loadable modules" disable  when compiling linux-...-xen kernel, then
> I designated grub parameters as:
> title xen remote
> kernel xen.gz dom0_mem=256000
> module vmlinuz root=/dev/nfs nfsroot=
> ip=
> then there occured NFS getport error, and kernel panic.
> That's weired for I had tested NFS server by nfsroot a normal Linux just
> before. So I booted again and tcpdump the eth0 of the nfs server. I found
> there was no
> nfs packet received at all!
> The most possibility is there's no network device working, but I did
> choose the my Intel PRO/100+ driver when compiling the kernel. 
> I tried  "loadable modules" and using initrd then , still no working.
> Anyone can save me?
> xugb04
> 2007-04-18
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

View this message in context: 
Sent from the Xen - User mailing list archive at Nabble.com.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.