[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xen hangs if running from lvm snapshot under heavy I/O

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "remigiusz boguszewicz" <remigiusz.boguszewicz@xxxxxxxxx>
  • Date: Wed, 18 Apr 2007 15:11:51 +0200
  • Delivery-date: Thu, 19 Apr 2007 02:26:06 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=LwDt359YJT+TFPNB8sLkCkrY/ww5NYSD7xNMajpkY1N2ICakNO5QJyluDrhe9H0ZLsoQUTiZF9Ru0/Wjg0nlmdZ0453ucsqHFXvxVQ9jbNW324HwToG4RkBlGiUErYaYcs6ajT9Tx8CKDoHlT16Jr2WZ8rMdNutivd5BqMDanDs=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


The situation is as follows:

Test system1:
Debian Etch - native xen packages -
kernel 2.6.18-4-xen-686, xen-3.0.3-1
lvm2 - 2.02.24-6

Test system2:
Debian Sarge - xen installed from binaries
kernel 2.6.16-xen, xen-3.0.2-2
lvm2 - 2.02.06-4

On both of those environments I am able to successfully run domU
instances that work perfectly well under heavy I/O load.

But the problem occurs if I try to run a domU from lvm snapshot. I
test it by transfering 1GB file with scp, but it also occurs if I
create a file with dd.

There is no log that could indicate the problem. I tried enabling the
debugging logging for lvm to no results.

I tried the underlying filesystem to be reiserfs and ext3 but it still
acts the same.

The hang of domU freezes completly the dom0 too. The only thing that
is left is reset the box.

What I do is:
on dom0 Snapshot creation:
lvcreate -L3000M -s -n twiki2-snap /dev/vg01/twiki2
mount /dev/vg01/twiki2-snap /mnt/twiki2-snap
xm create /etc/xen/twiki2-snapshot-config.sxp  -> which starts domU
that hangs :(

Any help would be gratly appreciated.

Remigiusz Boguszewicz

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.