[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] Block device sharing

Put a '!' after the 'w' (for read/write) in the config file.


> -----Original Message-----
> From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-users-
> bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Brad Plant
> Sent: Monday, 2 July 2007 12:44
> To: xen-users@xxxxxxxxxxxxxxxxxxx
> Subject: [Xen-users] Block device sharing
> Hi list,
> I have been successfully sharing block devices read/write between
> domains on different dom0's using ocfs2. This has worked well without
> incident until now when I tried to share the underlying block device
> between 2 domU's on the same dom0. I get the following message:
> Using config file "/mnt/xen/configs/machines/mail1".
> Error: Device 5633 (vbd) could not be connected.
> Device /dev/evms/shared/mail is mounted in a guest domain,
> and so cannot be mounted now.
> I read the following in the Xen users manual:
> Xend will attempt to prevent you from doing
> this by checking that the device is not mounted read-write in domain
> and hasn't already been exported read-write to another domain. If you
> want read-write sharing, export the directory to other domains via NFS
> from domain 0 (or use a cluster file system such as GFS or ocfs2).
> So xend is obviously successful in stopping me, but since I am using
> ocfs2, I would like to permit it anyway. I haven't managed to find the
> answer from google. Does anybody know how to tell Xen to allow block
> device sharing?
> Cheers,
> Brad

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.