[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] How to get a framebuffer console on dom0

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: p <p@xxxxxxxx>
  • Date: Mon, 16 Jul 2007 19:03:46 +0200
  • Delivery-date: Mon, 16 Jul 2007 11:01:40 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi all,

I'm trying hard to get a framebuffer console on a dom0 (Ubuntu 7.04/Debian Etch with (virtual)framebuffer support compiled it + Xen3.1) and already tried different tutorials, e.g. starting dom0 with kernel parameters
- "xencons=xvc console=xvc0 console=tty1"
- "xencons=ttyS0 console=ttyS0 video=xenfb" and appending "S0:2345:respawn:/sbin/mingetty ttyS0" to /etc/inittab

In both cases the framebuffer seems to be used (the fonts is small) while booting, but at a certain point ['Loading essential drivers'] the console went back to normal mode. I can see a /dev/fb0 device, too, but can't read from it and write to it seems to have no effect.

The same problem also happens on a domU (with sdl). After starting a domU, I receive a black window until I start a xserver. How can I get my console output on this "black window" and why am I not able to get any windows on the screen (tried fluxbox and saw workspaces and menus, but nothing happens when I start a program)?

Many thanks


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.