[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] BSD domU with HVM

Hash: SHA1

Daniel Bareiro wrote:
> On Monday, 16 July 2007 10:09:27 +0100,
> Martin Goldstone wrote:
>> Hi,
> Hi, Martin.
>> As it's going to be a HVM domain, the procedure is going to be the
>> pretty much the same as any other HVM domain, regardless of the OS.
>> The easiest way is to use virt-manager.  If you can't/don't want to
>> use this, then start with one of the examples (ie xmexample.hvm) which
>> you should have in your /etc/xen directory (assuming they're included
>> in the debian package). Just point the entries on the disk line to the
>> right places (If your using a real cdrom, then it'll be something like
>> phy:/dev/cdrom, if its an iso then its file:/path/to/image.iso, and
>> similarly for the hard disk images phy: for physical devices, lvm etc.
>> and file: for file based hard disk images.
> I'm newbie in HVM virtualization. For my initial test, I decided to use
> Debian GNU/Linux (netinstall CD). The config file for the domU is the
> following:
> alderamin:~# cat /etc/xen/xmexample.hvm |grep ^[^#]
> kernel = "hvmloader"
> builder='hvm'
> memory = 128
> shadow_memory = 8
> name = "ExampleHVMDomain"
> vif = [ 'type=ioemu, bridge=xenbr0' ]
> disk = [ 'phy:/dev/vm/debian.raiz,ioemu:hda,w', \
>          'phy:/dev/cdrom,ioemu:hdc:cdrom,r' ]
> device_model = 'qemu-dm'
> boot="cd"
> sdl=0
> vnc=1
> vnclisten=""
> stdvga=0
> serial='pty'
> Where is the dom0 IP. It is running vncserver and it is not
> running an X server. Then I try connect to domU via vncviewer (vncviewer
> from my worstatition with X, but I get a gray window
> and I don't see the Debian netinstall screen.

Hmm,  I've heard of a similar issue with graphical boot loader menus
before.  If I remember correctly, it was something to do with the CPU,
but I can't remember whether it was Intel or AMD that had the problem.
This may be related to your problem, but it might not be.  Have you
tried booting with a different CD? Perhaps one that just displays text,
not a framebuffer?

I've tested a similar config to the one above here, using an iso image
of the netinstall cd and a hard disk image (they were the only
differences), and it seems to work fine.  I'm using an Intel CPU though.
 You've said you're running vncserver, is this a separate vncserver to
the one that is launched by xen for that guest?  Either way, have you
verified that you are connecting to the correct port?  If it is the
correct port, are you seeing any output from the guest's BIOS?


>> Additionally, as you're using Xen 3.0.3-1, I'd be careful with the ACPI,
>> APIC and PAE settings, as I had problems with various combinations of
>> settings whilst attempting to install Win2k3 (I ended up with them all
>> set at 0 in that version, with just 1 VCPU.  Xen 3.1 really is much
>> better at HVM stuff, I'd suggest using that if you can).  That said,
>> I've not tried installing any BSD or Linux distro as a HVM under that
>> version, so it might be different.
> I've it in mind.
>> Hope this helps,
> Thank you for your answer.
> Regards,
> Daniel

Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Attachment: m.j.goldstone.vcf
Description: Vcard

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.