[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] HVM disc image switching

Hash: SHA1

I usually use 'xm block-configure domID file:/path/to/iso hdc:cdrom r'.
Often, it doesn't work the first time, but usually by doing it a second
time, and adding a second / after file:/, it works, sometimes with a
mysterious delay of several seconds.  Its also worked for me by starting
with 2 /'s and on the second time deleting one.  It almost never works
if I don't add or remove a /.

Now, there have been one or two occasions where I've had to take
additional steps.  I don't think ejecting it from within Windows has
ever helped me.

I know that this isn't ideal, but the alternative is to enable the qemu
console, which its inherent security implications.

Kevin DeGraaf wrote:
> I'm using Xen 3.1.0 on Debian etch, kernel 2.6.18-4-xen-amd64.
> One of the guests runs Windows XP.  I am trying to install an
> application (Autodesk Inventor) that spans two DVDs.
> The config file for the domain in question contains:
> disk = [ 'phy:/dev/volgrp0/halebopp,ioemu:hda,w', ',hdc:cdrom,r' ]
> I ran "xm block-list halebopp --long" and noted that the virtual optical
> disc drive had an ID of 5632.
> I ran "xm block-detach halebopp 5632 -f" and then "xm block-attach
> halebopp file:/path/to/disc1.iso /dev/hdc r".  The disc image was then
> available inside Windows.  So far, so good.
> I then ran "xm block-detach ...", right-clicked the drive in Windows
> Explorer and clicked "Eject", and ran "xm block-attach ..." with the
> path to the second ISO specified.
> At this point, Windows still showed the contents of disc #1, even with a
> refresh.
> I followed these suggestions to no avail:
>   http://tinyurl.com/35ghhx
> These instructions didn't help either:
>   http://tinyurl.com/3xlymb
> "xenstore-read /local/domain/0/backend/vbd/3/5632/params" reports that
> the second disc image is loaded, but the guest OS is not reflecting this
> change.  Something (Xen, qemu, Windows, etc.) seems to be broken here.
> If I specify an ISO file directly in the Xen .cfg file for this host and
> reboot it, the image is updated properly, but that doesn't help in my
> current situation.
> Am I missing something?  Thanks.
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Attachment: m.j.goldstone.vcf
Description: Vcard

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.