[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] OpenSuSE 10.2 Xen dom0 VNCViewer problem: Network is unreachable


I am using the Xen package that comes with OpenSUSE 10.2 (Xen 
Hypervisor). I used all the default settting when installing a Xen 
SuSE Linux VM (dom1) except I enabled the vnc=1 and textmode=0, so 
I can see the graphics console using the VNCViewer. I am installing 
the VM dom1 from the OpenSuSE 10.2 installation CD. During the dom1 
installation process, a text console pops up showing the VNC server 
in dom1 starting and the showing the required parameters one would 
need to open a graphics console to dom1 as follows: 

" starting VNC server ...
A log file will be written to /var/log/YaST2/vncserver.log ...

*** You can connect to, display :1 now with vncviewer
*** Or use a Java capable browser on

(When YaST2 is finished, closed your VNC viewer and return to this 
*** Starting YaST2 *** "

Following the instructions, I then open a console in Dom0 and 
entered this command:

vncviewer <enter>

I then got the message below: 

vncviewer: ConnectToTcpAddr: connect: Network is unreachable

I tried various variation of the vncviewer command
e.g. vncviewer, 
but I always got the same "Network is unreachable" message above. 

I tried to ping (this is the dom1 static IP address) from 
I still got the same "connect: Network is unreachable" message 
What is wrong with my networking? It is the default setting. 

Running the route command on dom0 shows the following result:
Kernel Ip routing table
Destination Gateway     Genmask       Flags    Metric  Ref  Use  
loopback    *      U        0       0      0  lo

Thanks. I really appreciate your help. 

Henry M. 

Click to learn how to make millions with hedge funds 

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.