[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen networking problem - OK on 3.0.2, broken on 3.0.4

I just confirmed that my methods work with Xen 3.0.2, and I'm not exactly sure why the same methods wouldn't work with Xen 3.0.4, which is the version I need to be looking at.

By "working", I mean that the "RUNNING" flag appears on the guest domain's vif when I run ifconfig and that the private networking between the host and the guests works.

I'll be investigating more into this issue; meanwhile, any input would be appreciated.


On Tue, 31 Jul 2007, Yongjun Jeon wrote:

Yes, I am using the BroadCom driver and not the kernel driver, and the driver is called 'tg3', as it states in the README file:

                          Installation Notes
                       Broadcom tg3 Linux Driver
                              Version 3.71b
                               12/15/2006 ...

I downloaded this from the BroadCom website http://www.broadcom.com/support/ethernet_nic/netxtreme_desktop.php. I believe the link you previously gave me (bnx2) is for BCM5706/BCM5708/5709, whereas I have BCM5754 (tg3).

Any clues? I'm still very lost.


On Tue, 31 Jul 2007, Hinrich Aue wrote:

I remember that the driver I downloaded from broadcom created a bnx2.ko
module that I then copied into the /lib/modules/2.6.18.xx/somewhere folder.

Are you sure the vorrect Broadcom driver (not the kernel driver) is loaded?


-----Ursprüngliche Nachricht-----
Von: Yongjun Jeon [mailto:yongjunj@xxxxxxxxxxxxxx]
Gesendet: Monday, July 30, 2007 8:08 PM
An: Hinrich Aue
Cc: xen-users@xxxxxxxxxxxxxxxxxxx; Yongjun Jeon
Betreff: Re: AW: [SPAM] [Xen-users] Xen networking problem

Hi Hinrich,

Thanks for your response.
I am using a BroadCom Corporation NetXtreme BCM5754 Gigabit Ethernet PCI
Express (rev 02), and I am currently using the BroadCom driver.
I've also tried the ethtool command you gave me, but it didn't work

Rather, here's what I saw when I did ethtool on vif's:

root@perodua:~# ethtool vif0.0
Settings for vif0.0:
        Link detected: yes
root@perodua:~# ethtool vif2.0
Settings for vif2.0:
        Link detected: no

So it seems that my HVM Windows XP guest is not "plugged in", hence no
"RUNNING" flag on ifconfig; how should I go about fixing this?

I'm even more confused now because the following post
suggests that a tg3 based machine (tg3 is the name of the BroadCom driver)
works out of the box with no hassle.

Any ideas? Any help is appreciated.


On Mon, 30 Jul 2007, Hinrich Aue wrote:

When you use broadcom network cards, try the Broadcom drivers instead of
linux kernel driver.


When you have other network cards, look at this:


or so. You have to make ethtool -K nicX tx off
while nicX is your network adapter or bridge.

Google for that a little more. You can adjust you scripts to do that
automatically on startup.


-----Ursprüngliche Nachricht-----
Von: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] Im Auftrag von Yongjun Jeon
Gesendet: Monday, July 30, 2007 6:31 PM
An: xen-users@xxxxxxxxxxxxxxxxxxx
Cc: Yongjun Jeon
Betreff: [SPAM] [Xen-users] Xen networking problem


I've been googling around for several days now, but with no luck. I'm

someone here might be able to help me out...

I've installed and run Xen 3.0.4 (I need this specific version) with no
problem, and the guests run smoothly; the only problem is that I have
been able to get the guests to ping the host (Dom0), or vice versa. I

access the internet from the guests, but it works fine on Dom0.

I have only one NIC on Dom0 (eth0) that connects to the internet. Right
just trying to get the guests and Dom0 to recognize each other, let alone
guests' internet access.

I've tried network-bridge, network-nat, network-route, and even some
scripts such as network-private
network-virtual (http://en.opensuse.org/Xen3_and_a_Virtual_Network), with

success. I've tried all I could, but here's one thing I believe is the
When I run ifconfig on Dom0, I see this on the guest's vif:

vif2.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          UP BROADCAST NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

As you can see, I don't see a "RUNNING" flag on guests' vifs.
Can anyone please help me out? I'm completely lost here.

If it helps, I'm running Ubuntu 7.04, and I'm experimenting with an HVM
guest (Windows XP).


Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.