[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Kernel Panic, no init found, after upgrading Xen & Kernel

  • To: "Xen Users" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Derek <xen@xxxxxxxxxxxxxxxx>
  • Date: Sat, 1 Sep 2007 14:33:05 -0600
  • Delivery-date: Sat, 01 Sep 2007 13:33:36 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:sender:to:subject:mime-version:content-type:x-google-sender-auth; b=GkXJsZVP6OHW74xAiY21Yf0G5caBtm6HntfQGr17jKFMWVBR5bXI3SoEJ6Y6LOlJBXMbwJ2t/xHXRF9a7rQtQU54t/cl5QC4NbUjoWn/ryoUf3B0F48+S4cHM9nQyrAlO9Cphb6DhO0cQ5Sid8YZFF/Odh12qmFurkfQ4n5sEoE=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi Folks,

I just tried to upgrade my X86 Xen system from Xen 3.0.4 + Dom0=kernel to Xen 3.1.0 + Dom0=kernel 2.6.18.

I have to build the kernel from source.  I use initrd, and have my root directory under LVM.

The system is Gentoo, running on an Core2-duo HP box.

I installed xen 3.1.0 from the tarball, and followed the instructions from the README file.  The only place I deviated from them was when I created the initrd, for which I used "lvm2create -M gentoo".  (This is exactly the procedure I have used in the past and it worked before.)

But when I try to boot my new Xen+Dom0, I get a kernel panic message:

    Kernel panic  - not syncing:  No init found.  Try passing init=option to the kernel.

Any suggestions what I might have done wrong?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.