[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Server moved - networking stopped

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Russell Horn" <albanach@xxxxxxxxx>
  • Date: Wed, 5 Sep 2007 18:12:07 +0100
  • Delivery-date: Wed, 05 Sep 2007 10:12:38 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=O2PDPKEty/hUei+yhzBcUux56TcdZh1Nb2WnEHa6fX6YP+MDUir6EzESXRzbtnqmCsDjWf9YyL8sHc1q4SN0/yKGeoCyO+GNv/af6CgW4GdHDVRvWhiOb6W4GJ0SQi5FwYQx7okw9HDikBzVcjUMDK48pabKtLgwoD1DRfKbjmw=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

This is all on SuSE enterprise 10

Our server was moved to a new location last night. After powerup there
was no sign of networking so our ISP reconfigured the box. Outbound
connectivity had previously been through eth1 but is now through eth0

Since restarting Xen I now have no network connectivity through the hosts.

I have tried to provide all the relevant details below. If anyone has
a moment to take a look and offer a suggestion as to why my networking
may be down, I'd love to hear it. Thanks.

Our configuration is as follows.

eth0      Link encap:Ethernet  HWaddr 00:1A:A0:05:7E:F9
          inet addr:  Bcast:  Mask:

We have routed through that IP

At the command prompt I did
# modprobe dummy
# ifconfig dummy0 netmask up

That gives me:

dummy0    Link encap:Ethernet  HWaddr 26:65:C6:05:99:96
          inet addr:  Bcast:  Mask:

Which looks okay.

I restart xen:

# rcxend restart

And my bridge appears:

xenbr0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet addr:  Bcast:  Mask:

starting a machine makes a vif appear too:

vif3.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link

The networking part of xend-config.sxp looks like this:

(network-script 'network-virtual bridgeip=""
brnet="" netdev="eth0"')

(vif-script vif-bridge)

The variables section in network virtual are:


I'm not aware of any changes to the vif-bridge script

I am unable to ping the vm from dom0

>From an external host I can ping the bridge IP

Traceroutes from an external host to do not receive a
reply from the bridge IP. I'm unsure if they should.

Traceroutes to (the bridge ip itself) do receive a reply.

The only vm config for networking is:

vif = [ 'mac=00:16:3e:9a:d4:33' ]

Where the MAC address is changed in each vm script.

As I say, this config worked until yesterday,  My only change today
was in xend-config.sxp changing eth1 to eth0

Thanks again,


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.