[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] Xen 3.1 on Debian Etch: Dom0 eth0 dead

  • To: "Florian Engelmann (Manntech)" <florian.engelmann@xxxxxxxxxxx>
  • From: "Fischer, Anna" <anna.fischer@xxxxxx>
  • Date: Tue, 11 Sep 2007 07:55:36 +0100
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 10 Sep 2007 23:56:41 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcfzxaszDsyvcwMHQIOS5P2flgwH1wAE0jzg
  • Thread-topic: [Xen-users] Xen 3.1 on Debian Etch: Dom0 eth0 dead

> Hi,
> I just installed a clean debian etch 4.0r1 with LVM on our 
> Dell PowerEdge 2900. The system has 2 Broadcom onboard NICs 
> and I also installed 2 Intel Pro 1000 NICs. I installed all 
> needed pakages and also dev86.
> The kernel booted also without any errors an i got my login 
> prompt. I tried to login with ssh from my workstation but 
> that did not work. So i tried to ping my Server what also 
> failed. An ifconfig gives me an eth0 device with my local IP 
> a lo device a peth0 device a vif0.0 device and a 
> xenbr0 device without any IP. I did not modify the 
> /etc/xen/xend-config.sxp and my /etc/network/interfaces looks 
> like this:
> iface eth0 inet static
>         address
>         netmask
>         #network
>         #broadcast
>         gateway
>         # dns-* options are implemented by the resolvconf 
> package, if installed
>         #dns-nameservers
>         #dns-search manntech.local
> auto eth3
> iface eth3 inet static
>         address
>         netmask
>         network
>         broadcast

Did you try to run any tracing tools (like Ethereal) to see if you
receive packets on any interfaces? Also, does "brctl show" display all
interfaces properly connected to the bridge? Does your routing table (ip
r) show correct entries?
> While eth0 is my default LAN interface and eth3 is my 
> crossover interface to the 2nd clusternode. If I change
> (network-script network-bridge)
> to
> (network-script 'network-bridge netdev=eth1')
> my eth0 works fine but any DomU I start does not get any 
> network connection.

Do you have both eth0 and eth1 configured and active with static IP
addresses? How does your ifconfig output look like when you run a DomU?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.