[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problem using tap:aio with disk on Scientific Linux (RHEL clone)


I was trying to install a paravirtualized guest on. My dom0 is Scientifc Linux 5.0 (a RHEL clone) and I tried installing both FC6 and SL5 and for both guest OSes, the installer would not find the disk I had specified (a regular file). I was using virt-manager to install them. After a couple attempts, I switched to the manual method with 'xm create'. With no luck, I eventually tried switching the disk to "file:" from "tap:aio" and then the install finally detected the disk. Here is my config file:

kernel = "/boot/vmlinuz-xen-install"
ramdisk = "/boot/initrd-xen-install"
name = "xenmachine1"
memory = "2048"
disk = [ 'file:/usr/scratch/cam/Xen/xenby,xvda,w', ]
vif = [ 'bridge=xenbr0', ]
on_reboot = 'destroy'
on_crash = 'destroy'

Does anyone know what the problem with tap:aio is? Is it a RHEL 5 issue that has been seen with CentOS or other clones? I'm a newb with Xen and would appreciate any pointers on how to get it to work better.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.