[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Boot error with 2.6.23 domU

Tomasz Chmielewski schrieb:
> I tried vmlinux, but also, it didn't work.
> It hanged at:
> # xm create -c somedomain
> Using config file "/etc/xen/somedomain".
> Started domain somedomain
> And it seems to wait there forever.
> Normally, I would expect:
> # xm create -c somedomain
> Using config file "/etc/xen/somedomain".
> Started domain somedomain
>  Linux version 2.6.18-xen (root@....

Same thing here, nothing happens. Usually you should at least hear the
hard drive working even if there wouldn't be any console output.
2.6.20-xen (from gentoo) is working just fine.

Basic system configuration:

- VIA C3-2 CPU (Nehemia)
- Xen 3.1.0
- dom0 kernel: 2.6.20-xen (from gentoo)
- domU kernel: I tried both 2.6.23 vanilla and 2.6.23-gentoo, with and
  without SMP support.
- domU kernel .config: http://www.boppstrasse.de/config-2.6.23-gentoo

`xm list` shows that the domU's CPU time doesn't increase if I compile
it without local apic support, it's stuck somewhere between 0.6 and 1.0
seconds. When I enable local apic, the CPU time does increase steadily.
`xm dmesg` shows nothing when I boot the domU kernel.

Can anybody send me a known to be working 2.6.23 kernel .config so I can
try if it works on my system?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.