[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] resetting lost root password on a xen guest

  • To: Darren Jacobs <dhj@xxxxxxxxxxxxxxx>
  • From: Nico Kadel-Garcia <nkadel@xxxxxxxxx>
  • Date: Tue, 30 Oct 2007 15:49:11 +0000
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Tue, 30 Oct 2007 08:48:41 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:user-agent:mime-version:to:cc:subject:references:in-reply-to:content-type:content-transfer-encoding; b=frRGwNn9HWneKjPfbm2+4st89cUqXY9uDznQpc6xsZ3ng/dnRn9Se+q9pZw7Etw1ejWRyCPYC702G0XwN2h3WZaVKrrYf4NuqEBTTWNLj9iFrNKGi7B5qdACvz+dkcV+1lgkVE2kP3xxkrobJDWkKjg1dIBa2wUwfrb38tqmihM=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Darren Jacobs wrote:
Hi All,

I need to get into a xenguest running linux for which the root password has been lost. I'm running xen 3.0.3 under RH 5.

I'm trying to figure out how to get pygrub for this guest to load up the typical "init=/bin/sh" to get the console to come up at the command line prompt so I can reset the root password.
Why? Can't you shut down the DomU, mount the DomU's "/" partitin, do a chroot to it, and edit it from the Dom0?

If not, you should be able to use "xm create -c domain" to get the grub console and boot into single user mode, unless you've been very fascist about your grub configuration.

Trolling though google I've see suggestions to add args = 'init=/bin/sh' or opts = 'init=/bin/sh' to the guest configuration file. None of them appeared to have worked. If I do a 'xen create echo11 -n' after making any of the above file mods I see that the args were not modified:

    (name echo11)
    (memory 500)
    (on_reboot restart)
    (on_crash restart)
    (vcpus 1)
    (uuid cb855323-2867-b84a-d766-32a39d252bb7)
    (bootloader /usr/bin/pygrub)
            (ramdisk /var/lib/xen/initrd.kIQYUw)
            (kernel /var/lib/xen/vmlinuz.Xwl81-)
            (args 'ro root=/dev/VolGroup00/LogVol00')
(tap (uname tap:aio:/var/lib/xen/images/echo11) (dev xvda) (mode w))
    (device (vif (bridge xenbr0) (mac 00:16:3e:69:69:90)))

So I tried to bring the guest up manually from dom0 with " pygrub /var/lib/xen/images/echo11.dsk". When the menu comes up I edit the kernel line directly and insert "init=/bin/sh". You can see below that the init statement was indeed read:
See, this is where you should use "xm create -c 'DOMAIN'"

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.