[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: Error: (9, 'Bad file descriptor')

  • To: "Xen Users" <Xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Anand Gupta" <xen.mails@xxxxxxxxx>
  • Date: Thu, 1 Nov 2007 01:21:31 +0530
  • Cc: Fedora Xen <fedora-xen@xxxxxxxxxx>
  • Delivery-date: Wed, 31 Oct 2007 12:52:23 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; b=P8QrylYeWx7Vd89FrOCFbZ3VcG/VYVHM952nRtVxoGosk4iSuPW5/CnOTJJN4Doejnzr2EM6QwdDRJkg2icm4Y31DgM3Llf5tM5wxWiywBggRy7xWF85HbTW45BLX/GHLeuYjDxbb8zChMxVt3T8/pttfb6J79LiXiW2H4GKiT4=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I also created a fresh domU using the wiki article located at http://wiki.centos.org/HowTos/Xen/InstallingCentOSDomU

After this since i have to use lvm, i created a new lvm volume, mounted the file, copied the first partition contents to the lvm volume. Now when i try to boot the lvm volume, it gives me the below error

mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

Here is the config file

name = "new2"
memory = "512"
disk = [ 'phy:/dev/VolGroup00/new2,xvda1,w',]
vif = [ 'bridge=xenbr0', ]
In the above i tried both xvda and xvda1, they give the same error.

/etc/fstab inside the lvm volume

/dev/xvda1              /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0

Any pointers / ideas on how to fix the problems will be appreciated.


Anand Gupta
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.