[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] HVM install keeps crashing with Centos 5 virt-install

Amos Shapira wrote:
> On 06/11/2007, *Fajar A. Nugraha* <fajar@xxxxxxxxxxxxx
> <mailto:fajar@xxxxxxxxxxxxx>> wrote:
>     Brian Lavender wrote:
>     >
>     > I am trying to install Redhat 6.2 as an HVM guest. Will this work?
>     >
>     >
>     First, a question. Have you ever tried to install RH 6.2 on a modern
>     Intel CPU?
>     My guess is it wouldn't work. CPU-wise, Xen will pretty much present
>     whatever CPU present at dom0 to domU. Meaning if it crashed on a real
>     machine, it would also crash on a HVM guest.
>     That being said, I believe the earliest RHEL version certified to
>     run as
>     HVM guest is RHEL3, and the earliest RHEL version certified to run
>     as PV
>     guest is 4.5.
> Really?
> Good to know - i've just spend a few days trying (and eventually
> succeeding) to install RHEL 4.4 x64 as a PV guest on an Intel Xeon 3050.
Just curious. You DO use RHEL4's kernel-xenU package, and not
CentOS/RHEL 5's kernel-xen for your domU, right? I believe kernel-xen
for RHEL4 is available starting from RHEL 4.5.

> Do you have a sample .cfg file to run an HVM RHEL 4 (on Debian Etch,
> Xen 3.0.3)?
No, sorry. Havent' had the need to create one.
says the steps (an therefore config) is the same as installing RHEL5

> Also - is there a way to run RHEL 4 i386 under Xen on an x86_64 host
> (and be presented as a i386 machine to its processes)? One of the
> things I tried was to start an HVM install but I just couldn't make it
> go. The only way i could make it run was using Qemu.
That's odd. It should work. I'll try it out later.
On another note, if you use Xen 3.1, you should be able to use dom0
x86_64 and domU i386 kernel, PV guest. I believe this is a better
approach since PV guests gives better performance compared to HVM.

> Attempting to run a jailtime i386 image on an x86_64 machine created a
> weird "Chimera" where the packages that came from jailtime's image ran
> fine but any execution of "yum" insisted on bringing in i686 packages

Why would i686 be a problem?



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.