[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] HVM install keeps crashing with Centos 5 virt-install

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Amos Shapira" <amos.shapira@xxxxxxxxx>
  • Date: Tue, 6 Nov 2007 16:23:21 +1100
  • Delivery-date: Mon, 05 Nov 2007 21:24:12 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=EnW1xE/S2UQuq7cQILx5m7/hwqoqYsRqljPmjEbUmk7/Bq9JpRNjSIzSdIbBNfK4BDXnMhgzzsn3R0AguYp2TDYCjzKYTwyR5z9Quo5NdaawkikYBU0PMMAErtIdG44HgIxkQ/cX3FyIwYfj9YeP8u5gFVFYOubWd1xyyAl1J1U=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On 06/11/2007, Fajar A. Nugraha <fajar@xxxxxxxxxxxxx> wrote:
Amos Shapira wrote:
> Good to know - i've just spend a few days trying (and eventually
> succeeding) to install RHEL 4.4 x64 as a PV guest on an Intel Xeon 3050.
Just curious. You DO use RHEL4's kernel-xenU package, and not
CentOS/RHEL 5's kernel-xen for your domU, right? I believe kernel-xen
for RHEL4 is available starting from RHEL 4.5.

I use Debian Etch for Dom0 (with Debian Etch's kernel), that's possibly the "original sin" that causes the rest of my problems.
I tried using also the kernel from xensource and RH's xen kernel but it didn't help they didn't boot or boot and got stuck early.

> Do you have a sample .cfg file to run an HVM RHEL 4 (on Debian Etch,
> Xen 3.0.3)?
No, sorry. Havent' had the need to create one.
says the steps (an therefore config) is the same as installing RHEL5

Yes, that's the problem - all my searches yielded references to "run these programs and get the right config" without giving the actual .cfg file content - I can't use these tools on Debian, can I?

> Also - is there a way to run RHEL 4 i386 under Xen on an x86_64 host
> (and be presented as a i386 machine to its processes)? One of the
> things I tried was to start an HVM install but I just couldn't make it
> go. The only way i could make it run was using Qemu.
That's odd. It should work. I'll try it out later.

There is big chance that i just didn't know how to configure the HVM correctly.

On another note, if you use Xen 3.1, you should be able to use dom0
x86_64 and domU i386 kernel, PV guest. I believe this is a better
approach since PV guests gives better performance compared to HVM.

Yes I read that 3.1 supports mixed 32/64. I tried to upgrade to 3.1 on Etch but it wasn't smooth and broke the little I already achieved so I rolled back to the "native" 3.0.3 ("native" in the sense that it's part of Etch).

> Attempting to run a jailtime i386 image on an x86_64 machine created a
> weird "Chimera" where the packages that came from jailtime's image ran
> fine but any execution of "yum" insisted on bringing in i686 packages

Why would i686 be a problem?

Sorry, I mixed up the RH arch names - it was trying to install 64bit versions (x86_64) not i686, pulling tons of basic packages with it (e.g. libc) and complaining about conflicts with existing packages or not being able to find others.

Right now the situation is that I'm able to run Centos 4.4 32 bit from Jaitime on Qemu, and Centos 4.4 and Centos 5.0 built using instructions from http://faiwiki.informatik.uni-koeln.de/index.php/FAI_multi-distribution#bootstrapping_the_base_images__for_other_distributions using Xen (and Windows 2003 Server HVM, but that's secondary :) all on Debian Etch and Xen 3.0.3 from Debian's packages on a Xeomn 3050 (VT enabled). Being able to run Centos 4.4 32 bit on Xen would make things a bit cleaner.

Thanks for your help.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.