[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] HVM install keeps crashing with Centos 5 virt-install

Amos Shapira wrote:
> On 06/11/2007, *Fajar A. Nugraha* <fajar@xxxxxxxxxxxxx
> <mailto:fajar@xxxxxxxxxxxxx>> wrote:
>     Amos Shapira wrote:
>     > Good to know - i've just spend a few days trying (and eventually
>     > succeeding) to install RHEL 4.4 x64 as a PV guest on an Intel
>     Xeon 3050.
>     Just curious. You DO use RHEL4's kernel-xenU package, and not
>     CentOS/RHEL 5's kernel-xen for your domU, right? I believe kernel-xen
>     for RHEL4 is available starting from RHEL 4.5.
> I use Debian Etch for Dom0 (with Debian Etch's kernel), that's
> possibly the "original sin" that causes the rest of my problems.
> I tried using also the kernel from xensource and RH's xen kernel but
> it didn't help they didn't boot or boot and got stuck early.

I'd say this is probably one of those times when having a vendor support
is great :)
FYI, I tried using custom-built Xen-3.1, which works like a charm for
Windows and Solaris HVM, but leaves RHEL 4 HVM with network problems :-P
For the time being I'm switching back to RH's Xen packages. This leaves
Solaris HVM with network problems though.
>     >
>     > Do you have a sample .cfg file to run an HVM RHEL 4 (on Debian Etch,
>     > Xen 3.0.3)?
>     >
>     No, sorry. Havent' had the need to create one.
> http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Virtualization-en-US/task-virt-lab1.html
>     says the steps (an therefore config) is the same as installing RHEL5
> Yes, that's the problem - all my searches yielded references to "run
> these programs and get the right config" without giving the actual
> .cfg file content - I can't use these tools on Debian, can I?
Having test it personally, this config should work
import os, re
arch = os.uname()[4]
if re.search('64', arch):
    arch_libdir = 'lib64'
    arch_libdir = 'lib'

kernel = "/usr/lib/xen/boot/hvmloader"

memory = 512

cpus = "^0"

vif = [ 'type=ioemu, mac=00:16:3E:BA:73:48, bridge=br128' ]

disk = [ 'phy:/dev/vg/rhel4lv,ioemu:hda,w',
         'file:/usr/src/iso/RHEL4-U5-i386-ES-disc1.iso,hdd:cdrom,r' ]

device_model = '/usr/' + arch_libdir + '/xen/bin/qemu-dm'



This config creates a VNC console with the same number as your domain
ID, so if after xm create your domain ID is 3, you can connect with
"vncviewer localhost:3"

Note that for installation I use "linux askmethod", and choose network
install (the CD is only for initial booting). It's easier than having to
change CD.
>     > Also - is there a way to run RHEL 4 i386 under Xen on an x86_64 host
>     > (and be presented as a i386 machine to its processes)? One of the
>     > things I tried was to start an HVM install but I just couldn't
>     make it
>     > go. The only way i could make it run was using Qemu.
>     >
>     That's odd. It should work. I'll try it out later.
> There is big chance that i just didn't know how to configure the HVM
> correctly.
HVM works.
You might also want to look at http://people.redhat.com/riel/RHEL4-Xen-HOWTO

>     > Attempting to run a jailtime i386 image on an x86_64 machine
>     created a
>     > weird "Chimera" where the packages that came from jailtime's
>     image ran
>     > fine but any execution of "yum" insisted on bringing in i686
>     packages
>     Why would i686 be a problem?
> Sorry, I mixed up the RH arch names - it was trying to install 64bit
> versions (x86_64) not i686, pulling tons of basic packages with it
> (e.g. libc) and complaining about conflicts with existing packages or
> not being able to find others.
It should't do that. I can run i386 domU's using x86_64 kernel just
fine. Then again, I use my own custom-built image :)
You might be able to work around that by changing all references of
$arch and $basearch to i386 on /etc/yum.conf and /etc/yum.repos.d/*.repo.

> Right now the situation is that I'm able to run Centos 4.4 32 bit from
> Jaitime on Qemu, and Centos 4.4 and Centos 5.0 built using
> instructions from
> http://faiwiki.informatik.uni-koeln.de/index.php/FAI_multi-distribution#bootstrapping_the_base_images__for_other_distributions
> using Xen (and Windows 2003 Server HVM, but that's secondary :) all on
> Debian Etch and Xen 3.0.3 from Debian's packages on a Xeomn 3050 (VT
> enabled). Being able to run Centos 4.4 32 bit on Xen would make things
> a bit cleaner.

If you use 32bit dom0, I'd recommend following RH's tutorial.

If you use 64bit dom0, for best performance I'd recommend using 64bit
kernel/32 bit Centos 4.4 domU. However, If you need kernel-specific
functions (like iptables, ipvsadm) you should stick with HVM domU.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.