[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen 3.1.0 and openSuse 10.3 - xenbr0 won't dissapear

I use xen for a few months now and I upgraded to opensuse 10.3 with xen 3.1 (64bit versions) recently. Everything works fine, but there is a problem when I change xend-config.sxp to use my own network script (it's slightly modified version of network-virtual scripts from http://en.opensuse.org/Xen3_yet_another_Virtual_Network_Concept ) instead of default network-bridge script. The problem is, that after restarting xend (and yes, I tried also a complete reboot of the whole system), there are not just my bridges xenbr1, xenbr2 and xenbr3, there is also a default xenbr0! I can remove it by "sh /etc/xen/scripts/network-bridge stop", but every time, when xend is restarted, it is there again. I use the same configuration like in previous version of xen, I doublechecked everything, I have even removed original network-bridge script, but the problem is still not solved.

Do you have any ideas, please?
I use the default configuration, the only change I made is one line in xend-config.sxp and adding my scripts to /etc/xen/scripts/ - and that scripts work fine, I tested them separately, they just create three bridges with IP addresses and add a few vlans to them.

Thank you,

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.