[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XEN 3.1 - eth0 Device Problems during booting

Hi Mark,

sure I will give as much as I can if someone can help me ;-)
Attached you will find the dmesg log files from a normal boot.

One dmesg from a boot sequence with a normal debian kernel without xen:
--> Logfile: ("dmesg.2.6.18-5-686-bigmem")
One dmesg from a boot sequence with XEN-Kernel:
--> LogFile: ("dmesg.2.6.18-xen")

Then we've tried it to via command "INSMOD":
With Debian normal: See attachement ("r8169-working.jpg")
And with XEN-Kernel: See attachement ("r8169-NOT-working.jpg")

For all we've used the Kernel 2.6.18.
You will find the whole bunch of Files in the attached ZIP-File: ("XEN3.1_r8169.zip").

Attachment: XEN3.1_r8169.zip
Description: Zip archive

Next to that we've tried the following as well:
We've done the lspci -vvv. The results are in the files lspci........ in the Archive.zip.
We did it once for the normal Debian-Kernel and for the XEN-Kernel, for you to see maybe some differences.

Last but not least, we tried to build a new world in XEN, with copying the r8169.c from the debian-source folder to the
XEN-source folder and compile it again. But without success. This was just a try with the other source-file from the debian source.

Attachment: Archive.zip
Description: Zip archive

ist still new and not assigned, so we don't know up to now if there'll something happen or not.

Many Thanks and nice Regards,
Maik Brauer

On Nov 28, 2007, at 12:08 AM, Mark Williamson wrote:

I'm facing some problems with the eth0 Device.
I've just used used the "make world" command to build a kernel and the
The System comes up and the prompt on the console (TTY) is there.
But the network card is not working. All the important drivers should
be available.

I will always get the following message in log:
Eth0: Device not found

I've added almost all thing into the config and have compiled it
several times without any success.
The network card is: Realtek RTL8169/8110 Family Gigabit Ethernet NIC

Is there any bug with that Driver in the XEN version??
What can I do. Any hints????

Can you please post the output of dmesg and of ifconfig?

Have you done lsmod to check that the module you built has loaded


Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.