[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] network-bridge does not create veth or peth devices


I am trying to install xen (64bit) on a Dell PowerEdge 2900.

The installation process was something like the following:

apt-get install iproute bridge-utils python-twisted binutils zlib1g-dev python-dev transfig bzip2 screen ssh debootstrap libcurl3-dev libncurses5-dev x-dev build-essential gettext python-pyopenssl python-pam python-xml latex tetex-extra tetex-base texlive-latex-recommended

hg clone http://xenbits.xensource.com/xen-3.1-testing.hg
cd xen-3.1-testing.hg/

make world
make install

apt-get install yaird
mkinitrd.yaird -o /boot/initrd.img-2.6.18-xen 2.6.18-xen
update-rc.d xend defaults 20 21
update-rc.d xendomains defaults 21 20

nano -w /boot/grub/menu.lst
# edited the following:

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=dom0_mem=512M com1=9600,8n1 vcpus=1
## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0 maxcpus=1 console=ttyS0,9600n8


after a reboot everything looks just fine, except:

ifconfig shows only a xenbr0, no peth or veth.. The network works, creating a guest with xen-tools works, however the bridging is weird:

$brctl show
bridge name     bridge id               STP enabled     interfaces
xenbr0          8000.00188b82f742       no              eth0

I installed debian minimal, maybe there are some packages that needs to be there in order to get this to work which i might have missed?

my config has network-bridge and vif-bridge enabled:
(network-script network-bridge)
(vif-script vif-bridge)

I've tried installing with the debs (3.0.3) from etch as well previously and gotten the same result (no veth/peth)

Has anyone experienced the same problem, and maybe found the solution?

Thx in advance

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.