[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Solaris domU dies at boot

  • To: Michael Jinks <mjinks@xxxxxxxxxxxx>, John Levon <levon@xxxxxxxxxxxxxxxxx>
  • From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
  • Date: Fri, 9 May 2008 02:15:28 -0700 (PDT)
  • Cc: Xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Fri, 09 May 2008 02:16:03 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:Cc:MIME-Version:Content-Type:Message-ID; b=o8EMJsvwxkCFfl5Is5m6ie+1dVwEZFSDOnCx5W1dvwORruH71o2apujJJWgWC94IxixpJnYWOzTGDkDgK25W81gs2/1+7O9BQgsfl7+eM/7l5DTbrv/yiDD5c9x8Mu5A4nGWlOCbkJqNnaAA4mreibKl/E4oeoPX0lARnvhpMbY=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

----- Original Message ----
From: Michael Jinks <mjinks@xxxxxxxxxxxx>
To: John Levon <levon@xxxxxxxxxxxxxxxxx>
Cc: Xen-users@xxxxxxxxxxxxxxxxxxx
Sent: Thursday, May 8, 2008 7:28:21 PM
Subject: Re: [Xen-users] Solaris domU dies at boot

On Fri, May 09, 2008 at 12:06:16AM +0100, John Levon wrote:
> On Thu, May 08, 2008 at 05:08:32PM -0500, Michael Jinks wrote:
> > The domU is trying to boot an ISO of the 2008/05 release of OpenSolaris.
> > I've copied i86xpv/kernel/amd64 kernel and /boot/x86.microroot from the
> > OpenSolaris ISO into the locations listed in my config file, and the
> > "extra" line is copied verbatim from the source linked above.
> OpenSolaris is different from the versions you tried before. In
> particular the extra line. See:
> http://blogs.sun.com/mrj/

Thanks.  I've read MRJ's blog at various points along my journey...

> Though you say you've been trying for weeks, so if both OpenSolaris and
> SXCE are crashing,

What's SXCE?

> it must be some other problem.

Oh yeah... :)

I've had several different problems at various stages.  For example,
using Nevada build 87 and Xen 3.2.0, I was able to get the install CD to
boot and install the system, but it would kernel panic when booting into
the installed OS.  Looking for the cause, I found some indication that
my trouble might be fixed by an upgrade, but since moving to Xen 3.2.1
and OS2008/05, I can't get the install CD to boot.

Yes, it's based on Nevada build 86 . You are supposed to failure.
John Levon's patch went into build 87.
View also:-

> add " -kd" to the
> options and it should drop you into the kernel debugger.

Okay, my Solaris kernel command line mojo is pretty weak... I changed my
"extra" line to read:

  extra = '/platform/i86xpv/kernel/amd64/unix -kd'

Was that right, or should I have left the "-B
console=ttya,livemode=text" parts in place?  At any rate, when I try to
boot with that I do get into the debugger.  Typing "::stack" returns:


Does that tell you anything?

> Also which builds of SXCE did you try?

I've only tried Nevada build 87 previous to this.

BTW, I've just logged into the IRC channel and I see you're there too,
would be happy to take this over there if it's easier.

Thanks much,

Xen-users mailing list

Be a better friend, newshound, and know-it-all with Yahoo! Mobile. Try it now.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.