[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XEN PCI passthrough

Geoff Gibbs wrote:

I am currently running Xen 3.3 unstable, and I trying to get PCI
passthrough to work with a Adaptec SAS RAID controller (4805SAS).

I am able to see the device on DomU but the aacraid module fails to
load with the following message:

aacraid: aac_fib_send: first asymchronous command timeout.
Ususally the result of a PCI interrupt routing problem; update the
mother board BIOs or consider utilizing one of the SAFE mode kernel
options (acpi, apic, etc)

Any ideas would be greatly appreciated. I have looked into adding
the aacraid card to, xend-pci-quirks.sxp and xend-pci-permissive.sxp,
but am not sure what the correct parameters I need to use.
While I am certainly not an expert with PCI passthrough, I did get it working on a system with the onboard USB controller. I ran into a problem where when I would load the USB modules in the guest, the guest would hang and I would have to destroy it. The fix that worked for me was putting the option 'swiotlb=force' in the 'extra' setting of the guest config. I'm not even entirely sure what it does. I found it through looking online. It might be worth a try.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.