[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] serial/terminal console problems

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Bruce Pennypacker" <bruce.pennypacker@xxxxxxxxx>
  • Date: Wed, 21 May 2008 10:10:59 -0400
  • Delivery-date: Wed, 21 May 2008 07:11:31 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:mime-version:content-type; b=Fy2NzAPHtnZJ4zz4xBJefmCMTvj5ehaTZlCxfN7DUt1kU70y3Rmjgzh1H2iFDKbMJRRfjKHCy6gY+S56sSyWU8fBv1iQqi/A3iesxQS1uchQBpbXgbPyZ+qw0DOh9GnlW05AZCniY7oi1qnCFyRTDLoGm5PauHYlcv20adWWoWk=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi all,

I have an environment running RHEL 5.1 (64-bit) and Xen 3.0.3.  When the server was first set up, prior to installing xen, it was connected to a serial console server and configured so that you could log in both from the terminal and the serial console.  We then installed xen and updated grub.conf in hopes of having Dom0 behave the same way.  Unfortunately nothing I've tried has worked.  We don't get any response from either the local terminal or the serial console.  I've read through a number of websites and posts to this list but none of the suggestions I've found have worked.  Here's what our grub.conf currently looks like:

serial --unit=0 --speed=57600
terminal --timeout=10 serial console
title Red Hat Enterprise Linux Server (2.6.18-53.1.6.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-53.1.6.el5 ro root=/dev/VolGroup00/LogVol00 console=tty console=ttyS0,57600
        initrd /initrd-2.6.18-53.1.6.el5.img
title Red Hat Enterprise Linux Server (2.6.18-53.1.6.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-53.1.6.el5 com1=57600,8n1 console=com1,vga
        module /vmlinuz-2.6.18-53.1.6.el5xen ro root=/dev/VolGroup00/LogVol00 xencons=ttyS0 console=tty0 console=ttyS0,57600
        module /initrd-2.6.18-53.1.6.el5xen.img

We also have the following defined in /etc/inittab:

co:2345:respawn:/sbin/agetty -L ttyS0 57600 vt100

So what are we doing wrong?  Why don't we get any response at all from either the terminal or the serial console?  Any suggestions would be greatly appreciated.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.