[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] serial/terminal console problems

> I have an environment running RHEL 5.1 (64-bit) and Xen 3.0.3.

That's the Xen shipped with RHEL 5.1, presumably?  It may interest you to know 
that it's not actually 3.0.3, as far as I've been able to tell.  It's 
effectively a later release of Xen, with the package being named 3.0.3 so as 
to fit in with the package naming scheme.  *I think.*

> When the 
> server was first set up, prior to installing xen, it was connected to a
> serial console server and configured so that you could log in both from the
> terminal and the serial console.

OK.  Sensible.

> We then installed xen and updated 
> grub.conf in hopes of having Dom0 behave the same way.  Unfortunately
> nothing I've tried has worked.  We don't get any response from either the
> local terminal or the serial console.

Right.  It should be doable somehow, it's something I believe other Xen 
developers use as part of their work!

> I've read through a number of 
> websites and posts to this list but none of the suggestions I've found have
> worked.  Here's what our grub.conf currently looks like:
> default=1
> timeout=5
> serial --unit=0 --speed=57600
> terminal --timeout=10 serial console
> hiddenmenu
> title Red Hat Enterprise Linux Server (2.6.18-53.1.6.el5)
>         root (hd0,0)
>         kernel /vmlinuz-2.6.18-53.1.6.el5 ro root=/dev/VolGroup00/LogVol00
> console=tty console=ttyS0,57600
>         initrd /initrd-2.6.18-53.1.6.el5.img
> title Red Hat Enterprise Linux Server (2.6.18-53.1.6.el5xen)
>         root (hd0,0)
>         kernel /xen.gz-2.6.18-53.1.6.el5 com1=57600,8n1 console=com1,vga
>         module /vmlinuz-2.6.18-53.1.6.el5xen ro
> root=/dev/VolGroup00/LogVol00 xencons=ttyS0 console=tty0
> console=ttyS0,57600 module /initrd-2.6.18-53.1.6.el5xen.img

The baud rate doesn't need to be specified on the Linux command line since Xen 
will set that up.  I suggest at least removing it just in case it's confusing 
something.  I've also found that specifying two console= lines on the kernel 
command line doesn't always work for me.  You could try just specifying one, 
although I don't really understand why you're not getting *any* output.

However, probably the most straightforward way to tackle this is to just 
concentrate on getting Xen to output on the serial line.  Drop the settings 
that try to make Linux talk through Xen to the serial line, drop the setting 
to try to make Xen talk vga at the same time.

Just concentrate on getting Xen to output its boot stuff to the serial port, 
which should be a case of just getting Xen's serial settings right.  Once 
that's done it should be (relatively) easy to figure out how to get Linux to 
output to it.  Also, this way you should be able to get a local Linux console 
whilst you're debugging, which may be useful.

Just as a sanity check, are you sure the com1=57600,8n1 is all correct, 

> We also have the following defined in /etc/inittab:
> co:2345:respawn:/sbin/agetty -L ttyS0 57600 vt100
> So what are we doing wrong?  Why don't we get any response at all from
> either the terminal or the serial console?  Any suggestions would be
> greatly appreciated.

Oh dear.  Not having any terminal at all is a bit unfortunate!

So you see no output whatsoever on the serial line?  Not even Xen boot 
messages?  If you send Ctrl-A three times does anything happen (this is a Xen 
special character sequence).


Push Me Pull You - Distributed SCM tool (http://www.cl.cam.ac.uk/~maw48/pmpu/)

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.