[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] ethtool - K eth0 tx off

aaron@xxxxxxxxxxxx wrote:
Hey Luciano,

Thanks for the information, while this does solve the problem. This feels more like a hack, rather than a permanent fix. Is this a bug in Xen, or is this something we should expect from now ?


Quoting Luciano Rocha <strange@xxxxxxxxxxxxx>:

On Mon, May 26, 2008 at 09:25:33AM -0500, aaron@xxxxxxxxxxxx wrote:
 Quoting Luciano Rocha <strange@xxxxxxxxxxxxx>:

> On Mon, May 26, 2008 at 10:53:02PM +1000, Aaron Weller // Crucial Paradigm
> wrote:
>> I recently setup a new Xen server, however whenever Xen was enabled it
>> was
>>  not possible to access ssh, etc.
>>  This was solved by doing: ethtool - K eth0 tx off
>> On CentOS (RHEL), what is the best way to ensure this happens everything
>> a
>>  server boots?
> cat >/sbin/ifup-local <<\EOF
> #!/bin/bash
> ethtool -K $1 tx off
> chmod +x /sbin/ifup-local

Thanks for this, will this also apply to all VMs as well? I noticed I'm also having the same problem in the DomUs as well now - I can resolve it by
 consoling into them, and using this: ethtool -K eth0 tx off

You'll have to install the script on the DomUs also.



It is a bug in Xen. In a few places in the network stack, there are some checksums made. Somewhere along the way an extra checksum is taken where it shouldn't. So the checksum doesn't match the packet anymore. On Windows clients, you'll notice this because you'll see dropped packets. On linux, you will nearly see it, because your linux box will try to use the packets even when the checksums do not match.

Can you tell me which version of Xen you are using? I've seen this on Xen 3.1 and I'm hoping that it is solved in Xen 3.2


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.