[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Problem with Windows 2003 domU's

Russell Foster wrote:
I was building a template for deploying Windows 2003 and all was working fine however I've hit an issue where trying to start Windows 2003 domU's isn't working and I'm ending up with

[root@LSN-D2066 ~]# xm list
Name ID Mem(MiB) VCPUs State Time(s) Domain-0 0 2442 4 r----- 23.7 newwintemplate.vm 4 511 1 ------ 0.0 vladawin.vm 5 511 1 ------ 0.0 wintemplate.vm 6 511 1 ------ 0.0

Where the time stays at 0.0. It was working fine and something obviously changed but I don't know what.

When starting the domU the interface is being added to the bridge device as I first thought it was a networking issue as tunctl wasn't installed

[root@LSN-D2066 ~]# brctl show
bridge name    bridge id        STP enabled    interfaces
xenbr1        8000.feffffffffff    no        vifwint01

If I start a Linux based domU that works fine on the same machine so I thought it was something to do with qemu but I can't see any errors in the logs.

I reset the xenstore via

rm /var/lib/xenstored/tdb

but still no go. I'm now pretty much out of ideas and would like some guidance on where to look / relevant logs snippits I can post



When I built Xen 3.3 from source, I had a similar problem getting Windows 2003 to start. My Windows 2003 HVM worked fine on Xen 3.0, but, not 3.3.

I did not build the hvmloader tool when originally building Xen 3.3. Once I built hvmloader and used the correct hvmloader in my vm config file, Windows 2003 booted normally on Xen.

Ken Cobler

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.