[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] RE: [Xen-devel] GPLPV drivers 0.9.12-pre9 upload

  • To: Venefax <venefax@xxxxxxxxx>
  • From: "Andrew Lyon" <andrew.lyon@xxxxxxxxx>
  • Date: Mon, 22 Dec 2008 20:19:11 +0000
  • Cc: James Harper <james.harper@xxxxxxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx, xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 22 Dec 2008 12:19:39 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references; b=g+FGpE74tlWddUI6+0vpEOZ7I1J1fCfPY/N1Mr/Jyw9r6nwTTeYnnQi6MF2BMVXlqZ Dxaz8M35mHu39RjAc/QPZ3jrcdktCYk/elwB9P5yOQhTFvF116G1LQ7Siv8TDBI64Nxe RkLEMV7J19kqiA+sDBoSVmsUSFFRsIIuZ0JuY=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

On Sun, Dec 21, 2008 at 6:48 AM, Venefax <venefax@xxxxxxxxx> wrote:
> Dear James
> I removed the offending service as well as other left overs from the Suse
> Drivers and now my windows blue screens with
> Stop: 0x0000007B(0xf789EA94,0xC0000034,00000000,000000)
> I have no idea how to boot Windows in safe mode. Is this possible? How do
> you press F8, and if you did manage to boot in safe mode, what then?
> Federico
> -----Original Message-----
> From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
> [mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of James Harper
> Sent: Friday, December 19, 2008 8:50 PM
> To: James Harper; xen-devel@xxxxxxxxxxxxxxxxxxx;
> xen-users@xxxxxxxxxxxxxxxxxxx
> Subject: [Xen-users] RE: [Xen-devel] GPLPV drivers 0.9.12-pre9 upload
>> 1. Windows 2000 is no longer included in the binary distribution. It
>> didn't work.
>> 2. qemu network and disk adapters are disabled, but will now appear as
>> having failed due to a change in the hiding code. This is cosmetic
>> (you'll get a warning on start that a service or driver failed to
> start)
>> but the effect is the same, except you won't get strange things
>> happening as a result of pci devices just disappearing - I was seeing
>> delays in places during startup and shutdown.
>> 3. If you are using the latest Xen 3.3.1 hg (maybe 3.3.0 too?), the
>> qemu_disable_patches.diff patch applied to the ioemu-remote git repo
>> (after 'make tools' has downloaded it, or after you've updated it to
> the
>> latest) will completely remove the ide disks and network interfaces,
>> leaving the cdroms as emulated by qemu. This is how things should be
>> going forward - qemu cdrom's means you get eject and virtual image
> swap
>> etc, and performance on a cdrom is hardly critical. Hopefully these
>> patches will make it into Xen 3.4.
>> 4. Please test in a dev environment. I haven't broken my test servers
>> during upgrade or anything, but testing first is just common sense.
>> 5. 64 bit block addressing is in place but not really tested. If you
>> have block devices >1TB that didn't work previously, please give it a
> go
>> and let me know.
>> 6. Save+restore is working for me at the moment, please report any
>> issues.
> Forgot one important thing. /GPLPV isn't required anymore. Use /NOGPLPV
> to disable the device drivers, or boot into safe mode which will also
> disable them.
> James
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

I installed the drivers into a existing Vista 32 bit HVM which had
older version of the drivers installed and it bsod on reboot with
0x0000007B, I tried /nogpl and also safe mode but neither worked, I
reinstalled Vista and tried again but I got the same result.

Once the qemu drivers have been disabled by booting with /gplpv (or
without /nogplpv in newer versions) is it sufficient to reset/reboot
the domain to boot without the drivers, or does it need to be
destroyed and created again for the qemu emulation to resume?

Fresh install of vista + 0.9.12 pre9 = 0x0000007B :(.

What do I need to do to debug this?

I am running 3.3.1 rc4, I can try 3.3  if you think it might help,
perhaps I need the patch for hiding devices?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.