[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xm pci-detach lockup

  • To: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Andrew Lyon" <andrew.lyon@xxxxxxxxx>
  • Date: Mon, 29 Dec 2008 09:56:30 +0000
  • Delivery-date: Mon, 29 Dec 2008 01:57:14 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references; b=OUVUkHqbRskbkffZp60YC8Y7Qy+ardsvCxtXGEB/7UAbgWzypAmUk+g0Xcq19amAmV CIdMiCDL9cqIWOF5cTRNFRJF8dtszVH7lJX5zhMHU8P/EQv52tb/VCn7yYL3C3utdvA3 NDrTHFELKHSMfUAJ0gnZzZKh4zQjcUmProz8Q=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On Fri, Dec 26, 2008 at 2:11 PM, Andrew Lyon <andrew.lyon@xxxxxxxxx> wrote:
> On Tue, Dec 23, 2008 at 8:10 AM, Andrew Lyon <andrew.lyon@xxxxxxxxx> wrote:
>> On Tue, Dec 23, 2008 at 5:20 AM, Todd Deshane <deshantm@xxxxxxxxx> wrote:
>>> On Mon, Dec 22, 2008 at 2:37 PM, Andrew Lyon <andrew.lyon@xxxxxxxxx> wrote:
>>>> Hi,
>>>> I have a NEC USB2 PCIx card which I assign to a Vista HVM by adding
>>>> pci = [ '0000:02:01.0', '0000:02:01.1', '0000:02:01.2' ] to the config
>>>> file, the card works well in Vista but if I try to detach it, destroy
>>>> the domain without shutting it down, or if the domain crashes, then
>>>> the entire machine locks up, I have a serial console setup but it is
>>>> completely unresponsive.
>>>> Combined with the issue that when the machine is under heavy load
>>>> Vista sometimes BSOD with "A clock interrupt was not received on a
>>>> secondary processor" this causes the system to lockup frequently :(.
>>>> I made sure to trigger safe removal of the device before detaching it.
>>>> Perhaps all 3 functions of the card need to be detached at the same
>>>> time? or am I wrong in assigning all 3 in the first place? they are
>>>> all listed when I run xm pci-list-assignable-devices and it seems to
>>>> be necessary to assign all 3.
>>>> Assigning the device by adding the setting to the config file, or
>>>> using xm pci-attach after the domain has booted does work, only
>>>> detaching causes the lockup.
>>>> This happens on my main workstation which is a Supermicro X7DWA-N
>>>> running Xen 3.3.1 rc4 (also tried 3.3 with fix for "ValueError:
>>>> unsupported format character ':' (0x3a) at index 6" and
>>>> fix_find_parent.patch), I usually use my own Gentoo ebuild for Xen
>>>> dom0 kernel which is with the openSUSE Xen patches rebased to
>>>> apply to vanilla without any of the other patches that openSUSE kernel
>>>> usually applies, but I have also tried using the interim 2.6.27 kernel
>>>> from http://xenbits.xensource.com/ext/linux-2.6.27-xen.hg with the
>>>> same result.
>>>> I replicated the problem on a Dell Optiplex 755 using the same
>>>> versions of Xen and kernel, but using a dlink network card which is
>>>> assigned as a single function (0000:02:01.0), it behaved exactly the
>>>> same, lockup on xm-detach.

I have done some more testing and found that xm pci-detach causes
lockup on all 3 of my test systems running Xen 3.3 or 3.3.1 rc4 with
2.6.28 or linux-2.6.27-xen.hg kernels.

I've not tried pci-detach with a pvm but I tried windows xp and vista
hvms, and I tried 3 different pci cards.


>>>> I seem to recall a commit recently for "hypervisor panic on domain
>>>> destory with passthru", but I cannot find it, anybody know where i can
>>>> find it and if it may help?
>>> Maybe this is the one:
>>> http://xen.markmail.org/search/?q=panic#query:panic
>>> list%3Acom.xensource.lists.xen-devel+page:2+mid:tfphqwwdstovpq5u+state:results
>>>> Thanks
>>>> Andy
>>>> Andy
>>>> _______________________________________________
>>>> Xen-users mailing list
>>>> Xen-users@xxxxxxxxxxxxxxxxxxx
>>>> http://lists.xensource.com/xen-users
>>> --
>>> Todd Deshane
>>> http://todddeshane.net
>>> http://runningxen.com
>> That patch appears to already be merged into 3.3.1 rc4, it must be a
>> different problem.
>> Andy
> I would really appreciate it if somebody could try xm pci-detach and
> report if it works or if they get the same lockup problem that I've
> had, I'd really like to get it working so that I can migrate hvm's
> with passthru devices.
> I also noticed another problem, I attached a Intel Pro 1000 PCI NIC to
> a running Windows XP HVM, the nic was detected and drivers loaded but
> in dom0 I got some messages about interrupts and the sata controller
> appeared to die, is it possible that the irq for the pci nic and
> onboard sata are shared? perhaps passthru should be disallowed in that
> case if it causes problems?
> Andy

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.