[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] grub boot problem

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: TamÃs Pisch <pischta@xxxxxxxxx>
  • Date: Thu, 2 Jul 2009 14:42:26 +0200
  • Delivery-date: Thu, 02 Jul 2009 05:43:57 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:from:date:message-id:subject:to:content-type; b=iIEMaNJf6wNiVYxQBksURdaP/QWkND8PQdgvWyAAhN5VVJR4Bly9XPaerGC67z6MvJ 5ZV5xUx0aXFBSrr0+twA/0/EEOV/WGrBQPoEiwB7Olzr5Ta0/uTc6+WmaUwvHueFx7hc AFxCScUaN3VSrBn510UOGCaK8+VJWJGgemiRQ=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I have a XEN installation on Debian Lenny. After a package update I rebooted, and grub doesn't start. The update replaced my grub.cfg, but it doesn't work. When I installed the system, I ran into that problem (grub error message "You need to load the kernel first"). At that time I found a solution, changed grub.cfg, and it worked. I tried that settings again, but it doesn't work! I get the error:
error: unknown command `module'
I can boot only the unmodified kernel. Here is my grub.cfg:
#bad entry:
menuentry "Debian GNU/Linux, linux 2.6.26-2-xen-amd64" {
ÂÂÂ set root=(hd0,1)
ÂÂÂ search --fs-uuid --set 81a70335-a810-444e-9247-1255491ff0ee
ÂÂÂ kernel /xen-3.2-1-amd64.gz dom0_mem=512M
ÂÂÂ module /vmlinuz-2.6.26-2-xen-amd64 root=/dev/mapper/xen-xensys ro
ÂÂÂ module /initrd.img-2.6.26-2-xen-amd64
##ÂÂÂ linuxÂÂÂ /vmlinuz-2.6.26-2-xen-amd64 root=/dev/mapper/xen-xensys roÂ
##ÂÂÂ initrdÂÂÂ /initrd.img-2.6.26-2-xen-amd64
#working entry:
menuentry "Debian GNU/Linux, linux 2.6.26-2-amd64" {
ÂÂÂ set root=(hd0,1)
ÂÂÂ search --fs-uuid --set 81a70335-a810-444e-9247-1255491ff0ee
ÂÂÂ linuxÂÂÂ /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/xen-xensys roÂ
ÂÂÂ initrdÂÂÂ /initrd.img-2.6.26-2-amd64

Thanks, in advance.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.