[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] grub boot problem

  • To: 'TamÃs Pisch' <pischta@xxxxxxxxx>, <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Tanuj Bansal" <bansal.tanuj83@xxxxxxxxx>
  • Date: Fri, 3 Jul 2009 09:18:08 +0530
  • Cc:
  • Delivery-date: Thu, 02 Jul 2009 20:49:22 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=reply-to:from:to:references:in-reply-to:subject:date:message-id :mime-version:content-type:x-mailer:thread-index:content-language; b=xyW5uvZKSWUPBdc4X1MmA6ARZ0Ojt56iHVbt9secTlSBx7nlrxfLe2NLdGcNr9tMay NInw18cIhkkQ4CsVNj6Ra0n6WGIhIs6zRyYYV6yz78q3olW/1P4mAbLG2G0qC5S+m0ZK ooBnpMa88SJ7G4FICG++LFr3hWvv4YlgJb0kg=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: Acn7EsnGi0estX4VShamjFcQAFwzxAAfHM3g

Seems bug there and a patch can fix this.


Check the below URL if they fix it.










Tanuj Bansal


From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of TamÃs Pisch
Sent: Thursday, July 02, 2009 6:12 PM
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] grub boot problem



I have a XEN installation on Debian Lenny. After a package update I rebooted, and grub doesn't start. The update replaced my grub.cfg, but it doesn't work. When I installed the system, I ran into that problem (grub error message "You need to load the kernel first"). At that time I found a solution, changed grub.cfg, and it worked. I tried that settings again, but it doesn't work! I get the error:
error: unknown command `module'
I can boot only the unmodified kernel. Here is my grub.cfg:
#bad entry:
menuentry "Debian GNU/Linux, linux 2.6.26-2-xen-amd64" {
    set root=(hd0,1)
    search --fs-uuid --set 81a70335-a810-444e-9247-1255491ff0ee
    kernel /xen-3.2-1-amd64.gz dom0_mem=512M
    module /vmlinuz-2.6.26-2-xen-amd64 root=/dev/mapper/xen-xensys ro
    module /initrd.img-2.6.26-2-xen-amd64
##    linux    /vmlinuz-2.6.26-2-xen-amd64 root=/dev/mapper/xen-xensys ro 
##    initrd    /initrd.img-2.6.26-2-xen-amd64
#working entry:
menuentry "Debian GNU/Linux, linux 2.6.26-2-amd64" {
    set root=(hd0,1)
    search --fs-uuid --set 81a70335-a810-444e-9247-1255491ff0ee
    linux    /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/xen-xensys ro 
    initrd    /initrd.img-2.6.26-2-amd64

Thanks, in advance.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.