[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] grub boot problem

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: TamÃs Pisch <pischta@xxxxxxxxx>
  • Date: Fri, 3 Jul 2009 08:54:36 +0200
  • Delivery-date: Thu, 02 Jul 2009 23:55:43 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:from:date:message-id:subject:to :content-type; b=ZW0fG9ezkBEWCeWA20jw5KW/HqHmw5Iznzs7JF+AqdwZz4CGYFa1ErAQNmeHrTmNGX 9VfId6eSz05VTbFHfH2bu28XhZdQ5wyJuttbOqE4AHrVvBV7gnmyMROfEduRBKuJ60rh ZNY9pXo8Cy1NGbc7dPh6a74lSmsOiokiPSU0Q=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Thanks for your answer. I've already known the second link, I tried it out.
I installed grub-legacy, and it works now. Maybe the syntax of the grub2 confused me, because, as I see now, in my post there is a kernel command, but it is a grub1 command in a grub2 config file. I don't want to try it out now, but maybe grub2 would work for me with the replaced command. It is not a xen related problem, it's my error. The only xen related problem is that I have to use 'module' parameters in order to boot the xen kernel.

Thanks, Tamas.

2009/7/3 Tanuj Bansal <bansal.tanuj83@xxxxxxxxx>

Seems bug there and a patch can fix this.


Check the below URL if they fix it.










Tanuj Bansal


From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of TamÃs Pisch
Sent: Thursday, July 02, 2009 6:12 PM
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] grub boot problem



I have a XEN installation on Debian Lenny. After a package update I rebooted, and grub doesn't start. The update replaced my grub.cfg, but it doesn't work. When I installed the system, I ran into that problem (grub error message "You need to load the kernel first"). At that time I found a solution, changed grub.cfg, and it worked. I tried that settings again, but it doesn't work! I get the error:
error: unknown command `module'
I can boot only the unmodified kernel. Here is my grub.cfg:
#bad entry:
menuentry "Debian GNU/Linux, linux 2.6.26-2-xen-amd64" {
ÂÂÂ set root=(hd0,1)
ÂÂÂ search --fs-uuid --set 81a70335-a810-444e-9247-1255491ff0ee
ÂÂÂ kernel /xen-3.2-1-amd64.gz dom0_mem=512M
ÂÂÂ module /vmlinuz-2.6.26-2-xen-amd64 root=/dev/mapper/xen-xensys ro
ÂÂÂ module /initrd.img-2.6.26-2-xen-amd64
##ÂÂÂ linuxÂÂÂ /vmlinuz-2.6.26-2-xen-amd64 root=/dev/mapper/xen-xensys roÂ
##ÂÂÂ initrdÂÂÂ /initrd.img-2.6.26-2-xen-amd64
#working entry:
menuentry "Debian GNU/Linux, linux 2.6.26-2-amd64" {
ÂÂÂ set root=(hd0,1)
ÂÂÂ search --fs-uuid --set 81a70335-a810-444e-9247-1255491ff0ee
ÂÂÂ linuxÂÂÂ /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/xen-xensys roÂ
ÂÂÂ initrdÂÂÂ /initrd.img-2.6.26-2-amd64

Thanks, in advance.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.