[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Re: NVIDIA, patches, PV_OPS and Xen 3.4.1

  • To: Michael Ralston <michael@xxxxxxxxxxxxx>
  • From: Andrew Lyon <andrew.lyon@xxxxxxxxx>
  • Date: Mon, 20 Jul 2009 19:57:44 +0100
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 20 Jul 2009 11:58:32 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=lcGpp5dfzu22HJp8r1WvGT7k735lMdQvIaIwhZv680iqUW+UMk71n+CWyNnPKHbiQf r4IJMag/nO/3fDmOrWHGeqgOdeIajvJXJoczOOam1cLWtoZZa3H04xk9FGUsphh8HniD 0qIKz9KuGp0v7GwkxuTMuO+Bvw5n859GC4fVY=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On Mon, Jul 20, 2009 at 12:52 AM, Michael Ralston<michael@xxxxxxxxxxxxx> wrote:
> When I start X with an nvidia driver, the screen goes black and the
> keyboard does not respond. I can remote ssh into the machine, but if I
> try to list the processes running on the machine 'ps -ef' the ps
> command stops at the process before where the Xorg process should be.
> ctrl-c will not terminate the 'ps -ef' command. If i try to remote
> reboot the machine it does not respond to 'init 6', it just acts as if
> you never told it 'init 6'. A hard reset is required to get the
> machine useful again.

Which kernel are you using? I had no success with the xensource 2.6.18
or the 2.6.20/21 that are in Gentoo portage, it was this which
initially prompted me to rebase the opensuse xen patches and release a
updated kernel ebuild, the first kernel which worked for me was

I have you tried running strace on the X process when it is in this state?

Can you post the X.org log ? (probably /var/log/Xorg.0.log)

> Boris seems to think this is because I have a slightly older geforce
> 7900gt, what do you think? My mother has a geforce 8600 in her pc, I
> might see if I can borrow it before I tell my wife I need to buy a new
> video card.

Might be worth a try, I had problems with the first card I tried which
I believe was a 9600GT,

> I'm also thinking of installing hardy, as it has more versions of xen
> precompiled for it, maybe one of those will work.
> -- Michael

Again might be worth a try, I've only ever used Xen that I've compiled
on the system itself.


> On Mon, Jul 20, 2009 at 6:54 AM, Andrew Lyon<andrew.lyon@xxxxxxxxx> wrote:
>> On Sun, Jul 19, 2009 at 4:34 AM, Michael Ralston<michael@xxxxxxxxxxxxx> 
>> wrote:
>>> On Sun, Jul 19, 2009 at 4:19 AM, Andrew Lyon<andrew.lyon@xxxxxxxxx> wrote:
>>>> 185.18.14 seems to work ok with kernel 2.6.30.
>>>> Andy
>>> Which Xen version is that with?
>>> I've unsuccessfully tried 3.3.0, 3.3.1, 3.4.0 and 3.4.1 with kernel
>>> and pv_ops kernel, with all versions of nvidia drivers.
>>> I'm using a 7900GT.
>>> -- Michael
>> I am using v3.4, and I also go it working with 3.3.X.
>> What problem do you have?
>> I'm going to add a second 8600GT card soon to use with windows7 using
>> passthru, I've already rebased the flr code to 2.6.30 and plan to port
>> the other necessary bits of kernel/xen code to 2.6.30/2.4.x soon :).
>> Andy

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.