[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Problems with xen and linux 2.26.32 kernels

  • To: "Fajar A. Nugraha" <fajar@xxxxxxxxx>
  • From: Jia Rao <rickenrao@xxxxxxxxx>
  • Date: Wed, 16 Jun 2010 21:54:38 -0400
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Wed, 16 Jun 2010 18:56:01 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=jDLv62XeSGIqwJow6PyrB8+bN4vhCa/CCu0tKQ72yKGylKJgohVB6xPXqDQus1MgCh 8dqWVxIlE/nEgEE+r+TfqaqI8nal5i8lDIV5SApwUS7FaCHbXOoQ7tEWHIsrY68DmaNq bnfpsl26/FmWH1+oKQK7eOKCGiXrqS0VRFZLw=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On Wed, Jun 16, 2010 at 9:29 PM, Fajar A. Nugraha <fajar@xxxxxxxxx> wrote:
On Thu, Jun 17, 2010 at 1:51 AM, Jia Rao <rickenrao@xxxxxxxxx> wrote:
> Hi all,
> I used to use xen 3.4.2 and linux 2.6.18-xen kernels for both dom0 and domU,
> without any problems.

You didn't mention which distro/version you use.

> Recently, I need to try io bandwidth control like dm-ioband in the new
> kernel 2.6.32 (dm-ioband has patches for this kernel). It gave me a lot of
> problems if I want to upgrade the dom0 to 2.6.32. The following is what I
> tried and the errors.

Any particular reason wanting to use 2.6.32? IMHO, the most "stable"
kernel-xen version out there is still currently RHEL's 2.6.18 kernel
(although it's missing some of newer Xen features)

I want to try dm-ioband whose latest version has patches only for 2.6.32

> Xen: 3.4.3 (I need to stick with 3.4.x. 3.4.3 is the one that can run pvops)

You might want to try Xen 4.0. 3.4.3 might not have all the support
needed to run 2.6.32 kernel:

> First approach:
> I tried to download pvops from the git repository xen/stable-2.6.32.x. The
> compilation was OK, but the initrd has a lot missing dependencies. I tried
> to use --builtin to claim those missing modules in kernel.

Did you actually have it built in? Missing usb modules are usually OK,
missing disk drivers are not. 

> However, with the
> generated initrd, dom0 can not boot. I got the error: unable to locate
> IOAPIC for GSIx and mount: could not find filesystem: /dev/root.
> tried to use root=/dev/sdax or root=LABEL=/. No luck.

It's best to start with known good kernel config (in my case it was
RHEL5's kernel-xen config), the add/adjust whatever's necessary in
newer kernel (including selecting pv_ops dom0 support). I use this
config on pv_ops, on top of RHEL5, which works fine:

> Second approach:
> Then I switched to the forward ported kernel generated from the
> gentoo xen kernel patches.
> Still xen 3.4.3. After compilation, dom0 booted successfully. However I
> previous domU which has 2.6.18-xen kernels can not boot.

Any particular reason to switch domU to 2.6.32 as well?

I am wondering if it is the problem of centos (RHEL5) with the new kernel. I can boot all my domUs on a machine: Xen 3.4 + 2.6.18 dom0. When I boot the same domU under the new forward ported 2.6.32 kernel, the VM timed out and prompt:
Error: Device 0 (vif) could not be connected. Hotplug scripts not working.
Probably it is the RHEL5 udev scripts that is not compatible with the new kernel.
BTW. domU still has 2.6.18 kernel, only dom0 changed.

> It has the same
> error: mount: could not find filesystem: /dev/root
> Do I need to create a initrd for the domU? I didnt need one when dom0 is
> 2.6.18-xen kernel.

It depends on kernel config and distro.

I prefer to use pygrub/pvgrub for domU kernels. That ensures domU is
somewhat independent of whatever kernel dom0 is running. In your case,
the easiest way would be to use 2.6.18-xen kernel for domU, while
using 2.6.32.x for dom0.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.