[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Complete Xen n00b getting stuck trying to create a VM

  • To: "Fajar A. Nugraha" <fajar@xxxxxxxxx>
  • From: Ewan Slater <ewan.slater@xxxxxxxxxxxxxx>
  • Date: Tue, 22 Jun 2010 09:16:49 +0100
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Tue, 22 Jun 2010 01:18:10 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=googlemail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=Uq+ckGrzezzSNS1lYLtu8UqGjz1mvdpaF4UoqoZQG6ooBxKz4TBpG/nxdbTAq0QEB0 pWbBVlZ6o5C0WWK4fZ8x10twAM4fDoiBhHpIPr+lFyn/ATtzFpQlyLO3GJ4nUvcCS0Tj t5dAwjxJ0PF0XzLLn0IP4VUUchKBd0Zo4cb9I=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Thanks for the tip.

Set up httpd and mounted iso as suggested.

Confirmed that I can browse to the contents of the iso using FireFox.

Started the install using virt install.

Then the installer in the VM tells me that it is "unable to retrieve";.  Note the "//" after the
ip address.  I am definitely not putting a second slash in there when
I specify the URL.

As I said, I can browse to the URL just fine, and see stage2.img.

Any suggestions?



On 22 June 2010 03:01, Fajar A. Nugraha <fajar@xxxxxxxxx> wrote:
> On Tue, Jun 22, 2010 at 1:21 AM, Ewan Slater <ewan.slater@xxxxxxxxxxxxxx> 
> wrote:
>> I then try to create my first vm with virt-install --prompt, and give
>> the path to the .iso for CentOS.
> That won't work. Basically virt-install and RHEL/Centos installer issue.
>> How can I get it to read the .iso that I specified on the command line?
> You can't. Not directly.
>> I have tried exporting the directory containing the .iso through NFS,
>> I've checked I can mount the directory via NFS and then tried to use
>> this but no dice ("That directory could not be mounted from the
>> server").  I then tried mounting the .iso as a directory on the host
>> file system, and exporting that directory via NFS, but got the same
>> result.
> That SHOULD work. Perhaps some IP range or path mixup?
> IMHO, the easiest way is to simply use http. Something like:
> - install httpd on your dom0
> - create /var/www/html/iso
> - mount your ISO there
> - use http://ip_of_your_dom_0/iso as installation source.
>> What I would ideally like to do is to tell the VM I'm creating that it
>> has a CD/DVD-ROM attached and to point it to the .iso file.
> Again, you can't. Opensolaris can do it just fine. RHEL/Centos
> currently can't do it when installing as PV guest, thus the http
> workaround needed.
> --
> Fajar

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.