[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Install Ubuntu Server 10 as PV Guest

  • To: "Fajar A. Nugraha" <fajar@xxxxxxxxx>
  • From: KC LO <kclo2000@xxxxxxxxx>
  • Date: Tue, 22 Jun 2010 17:59:37 +0800
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Tue, 22 Jun 2010 03:01:52 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=p++yGW8RH6NrxM58pWRmkkBOVK69OkDyzQltiivx0DPkrRXMP8eAKU4sQmQ1c+SRfh QcsWY/yBldIHrFLZOvRjgkrI7Hs5pTYtOprmYiws/ufHlbaRoo8b2duaooeGp47JQBuo S2jnME09cfGXX8D+scrMNieAQcpTOfMl1S4bw=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi all,
Thanks for your advice.  I follow procedure from Ubuntu website on removing grub2 and intsall grub.  I can use pygrub to boot the ubuntu.  One more things that I have changed is that the /boot/grub/menu.lst is using uuid to refer hard drive of ubuntu.  I need to remove all uuid keywords in the file and use /dev/xvda instead.  Otherwise, pygrub can't understand uuid

On 22 June 2010 08:57, Fajar A. Nugraha <fajar@xxxxxxxxx> wrote:
On Mon, Jun 21, 2010 at 10:19 AM, KC LO <kclo2000@xxxxxxxxx> wrote:
> I have copied kernel and ramdisk to the DOMU and it worked fine even the
> /boot is under partition of ext4.

You mean copy to dom0, right?

> However, the pygrub still fails for partition of ext3 with same error.

You mean you reinstall domU's so it's ext3 now?

> Below is my DOMU config
> name = "test"
> memory = "2048"
> bootloader="/usr/bin/pygrub"
> extra = "(hd0,0)/grub/menu.lst"

pygrub does not need "extra" line. pv-grub does.
Also, if /boot is not its own partition, the "extra" line for pv-grub becomes

extra = "(hd0,0)/boot/grub/menu.lst"

> When I replace with kernel and ramdisk, ubuntu can boot successfully.  Any
> ideas?

So it's down to pygrub problem now.
Not really sure what the problem is. It might be a problem with pygrub
parsing grub2's config file, but I'm not really sure. Perhaps you can
try uninstalling grub-pc on domU (which is grub2, the default for
Lucid), and use grub (the legacy grub) instead. Afterwards, make sure
there's a /boot/grub/menu.lst with the correct entries (you might need
to run update-grub first)


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.