[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Did anyone succeeded in installing xen 4.0.0 on Debian Lenny?

On Tue, Sep 7, 2010 at 10:47 PM, Carsten Schiers <carsten@xxxxxxxxxx> wrote:

it definitely works. I am not sure though, whether we talk about distro xen and distro
kernels here.

What I confirm working is: Debian Etch and Lenny, Xen 4 self-compiled with XenLinux 2.6.18
Kernerls. It's no miracle, thanks to Pasis XenWiki pages. Install tools, hg pull the source,
make xen tools (at least), ./install.sh. Remember to setup the Xen network scripts correctly.

Be very careful when using the options Pasi is describing. Be aware, whether you put in a Xen
or a Kernel option. Read the logs carefully. Check with lspci in Dom0 and DomU.

What doesn't work is handling devices with MSI in Lenny distro Xen/Kernel. Use pci=nomsi
as Kernel option and it should work with Lenny Xen kernel. It is the basis of a German
distri (c't server) and should work, although I still prefer XenLinux 2.6.18 for my DomUs
that use PCI passthrough (for NICs and DVB-C cards).

Be aware about the udev mechanism to create new entries in /etc/udev/rules.d/70-persistent-net-rules (or similar). You might have ended up with severeal entries and your NIC is not
eth0, because the DomU was started with a Xen virtual device before, or some, as Xen sets
a random MAC address.

You can disable this above "feature" with the patch below: (At least this works for Ubuntu 10.04) 
It just comments out the line that writes the new rules entry.

--- /lib/udev/rules.d/75-persistent-net-generator.rules 2009-05-14 02:28:14.000000000 -0700
+++ /lib/udev/rules.d/75-persistent-net-generator.rules.new     2010-05-26 14:34:25.000000000 -0700
@@ -54,7 +54,7 @@
 ENV{COMMENT}=="", ENV{COMMENT}="net device ($attr{driver})"
 # write rule
-DRIVERS=="?*", IMPORT{program}="write_net_rules"
+# DRIVERS=="?*", IMPORT{program}="write_net_rules"
 # rename interface if needed


What is not working for me currently, is: pvops and PCI passthrough, but some of the DomUs
are running a pvops 2.6.32 Kernel in parallel. I did not really try PCI passthrough with
XenLinux 2.6.32, but sucessfully compiled it and run it w/o PCI passthrough.

Hope this makes you a bit more confident in solving the problem instead of giving up ;o).

If you already knew about all these things, please excuse.


----- Originalnachricht -----
Von: Mark Adams <mark@xxxxxxxxxxxxxxxxxx>
Gesendet: Mit, 8.9.2010 00:39
An: Pasi Kärkkäinen <pasik@xxxxxx>
Cc: Meister Schieber <meisterschieber@xxxxxxxxx> ; xen-users@xxxxxxxxxxx ; xen-users@xxxxxxxxxxxxxxxxxxx
Betreff: Re: [Xen-users] Did anyone succeeded in installing xen 4.0.0 on Debian Lenny?

As Pasi says it does work, I am using it to passthrough a nic. Out of your options only the xen-pciback.hide on the kernel command line was required for me, plus of course the config in the vm.cfg file.

In your xm dmesg does it show that the device was successfully hidden? What do you get from xm list-pci-assignable-devices? (sorry that may not be 100% accurate command it's something like that)

I did have issues with 1 quad port Gb pci-e card. It would hide correctly but the domU would not load it as an interface (I think now maybe because the domU was Lenny not tested that theory though).

Can give you some more detailed config tomorrow if required.


On 7 Sep 2010, at 18:19, Pasi Kärkkäinen <pasik@xxxxxx> wrote:

> On Tue, Sep 07, 2010 at 12:22:24PM +0000, Meister Schieber wrote:
>>   From: Mark Adams <mark@xxxxxxxxxxxxxxxxxx>
>>> You should just use Squeeze (which is frozen now so on it's way to
>>> being the new stable). It works well simply by installing the
>>> xen-linux-system and xen-qemu-dm packages. It includes pciback.
>>   Tried that for the last days, did not work either. The installation of
>>   squeeze and xen 4.0 was very easy indeed, only the pci-passthru does not
>>   work (tried 3 different computers with different hardware).
>>   Regarding to [1]http://wiki.xensource.com/xenwiki/XenPCIpassthrough I used
>>   the options:
>>   xen-pciback.hide=(09:00.0)
>>   and
>>   pciback.permissive pciback.hide=(09:00.0) pci=resource_alignment=09:00.0
>>   and
>>   xen-pciback.permissive xen-pciback.hide=(09:00.0)
>>   pci=resource_alignment=(09:00.0)
>>   combined with "swiotlb=force" and "iommu=soft swiotlb=force" in the DomU
>>   (the "official" wiki has no special entries for the current release 4.0,
>>   so I tried every combination...)
>>   It just does not work, either the domU does not even start with some of
>>   the options, or the domU starts but the nic does not come up.
>>> If you are so far into setup now that you want to stick with it, you
>>> could try the linux-image-2.6.32-5-xen-amd64 kernel from the debian
>>> repos.
>>   I am so far into several setups (plural) that I just does not want to give
>>   up and switch to vmware, so I desperately ask again: Did anyone succeeded
>>   in installing xen 4 on _any_ Debian version _and_ got a passed through NIC
>>   working in the DomU?
> Yeah just yesterday someone was doing it.. and writing to ##xen on irc.
> What domU kernel are you using? Does it have xen-pcifront?
> What does "lspci" show in the domU?
> What pci related do you have in the domU dmesg?
> -- Pasi

Xen-users mailing list

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.