[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xm new yields Import error: No module named xmlproc

     I'm using a source-compiled Xen-4.0.2-rc1-pre (changeset: Fri Sep
17 17:06:57 2010 +0100 21350:6e0ffcd2d9e0) on a brand new Debian Testing
(Squeeze/sid) install.  The first problem that I ran accross was just
getting xend to start.  I was getting a python error saying that it
couldn't import SrvDaemon.  I got around that by moving
/usr/lib/python2.6/site-packages/xen to
/usr/local/lib/python2.6/dist-packages/xen, putting a symlink in
/usr/lib/python2.5/site-packages pointing to the "xen" directory in
/usr/local/lib/python2.6/site-packages, and putting a symlink in
/usr/lib/python2.6/site-pacakges doing the same thing.

     After doing that, xend starts, but if I try to do xm new, I get this:

Unexpected error: <type 'exceptions.ImportError'>

Please report to xen-devel@xxxxxxxxxxxxxxxxxxx
Traceback (most recent call last):
  File "/usr/sbin/xm", line 7, in <module>
  File "/usr/local/lib/python2.6/dist-packages/xen/xm/main.py", line
3620, in main
    _, rc = _run_cmd(cmd, cmd_name, args)
  File "/usr/local/lib/python2.6/dist-packages/xen/xm/main.py", line
3644, in _run_cmd
    return True, cmd(args)
  File "<string>", line 1, in <lambda>
  File "/usr/local/lib/python2.6/dist-packages/xen/xm/main.py", line
1449, in xm_importcommand
    cmd = __import__(command, globals(), locals(), 'xen.xm')
  File "/usr/local/lib/python2.6/dist-packages/xen/xm/new.py", line 26,
in <module>
    from xen.xm.xenapi_create import *
  File "/usr/local/lib/python2.6/dist-packages/xen/xm/xenapi_create.py",
line 23, in <module>
    from xml.parsers.xmlproc import xmlproc, xmlval, xmldtd
ImportError: No module named xmlproc

     I found this post from 2007:


... and the follow-up suggests installing the python-xml package, but on
my system, aptitude install python-xml says "no candidate version found
for python-xml".  It seems like it has been removed from the Squeeze
version of Debian, entirely.  I tried installing python2.5 and grabbing
the python-xml .deb file from packages.debian.org (for lenny), but upon
trying to install it, it complains about needing python < 2.6 - even
though both python 2.5 and python 2.6 are installed.  I even tried
forcing it to install despite the dependency problem, and I still get
the import error from xm new.  The error message doesn't indicate in
what path it is looking for xmlproc, so I'm not sure how to even begin
to nudge it in the right direction.

     Has anyone run across this problem and found a resolution?  I'm
somewhat stumped by it.  I know I can try just re-installing and using
Debian stable instead, then rebuilding everything with python2.5 at the
core, but that seems more like a step back than a step forward, so I
thought I'd check here first.

Scott Garron

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.