[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xm new yields Import error: No module named xmlproc

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Mark Pryor <tlviewer@xxxxxxxxx>
  • Date: Fri, 24 Sep 2010 01:43:17 -0700 (PDT)
  • Delivery-date: Fri, 24 Sep 2010 01:44:39 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=MgTY78oIVv2d/KflvP2sJzLcQvdEDl/A77V9xcXlx2LQEA//ZPUzVCUZL1Vm5cSCows5yyTfvbHrGqvjlKeiTDcLWiNJt/pQqeZv8PHrz9LwPxgLqLUy5juAQ3EVtNToLTrBCniJEL1rJ8rGr5mVm+HVE79yeULesTFzVT52VDo=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

> From: Scott Garron <xen-users@xxxxxxxxxxxxxxxxxx>
> Subject: [Xen-users] xm new yields Import error: No module named xmlproc
> To: xen-users@xxxxxxxxxxxxxxxxxxx
> Date: Thursday, September 23, 2010, 2:12 PM
>      I'm using a source-compiled
> Xen-4.0.2-rc1-pre (changeset: Fri Sep
> 17 17:06:57 2010 +0100 21350:6e0ffcd2d9e0) on a brand new
> Debian Testing
> (Squeeze/sid) install.  The first problem that I ran
> accross was just
> getting xend to start.  I was getting a python error
> saying that it
> couldn't import SrvDaemon.  I got around that by
> moving
> /usr/lib/python2.6/site-packages/xen to
> /usr/local/lib/python2.6/dist-packages/xen

During the build use below to make the prefix /usr/local
make install-tools PYTHON_PREFIX_ARG=

This worked for me for all builds on Karmic and Lucid Ubuntu.

> if I try to do xm new, I get this:
> Unexpected error: <type 'exceptions.ImportError'>

Its the same on Karmic and Lucid, but there is an unsupported Deb which
works as is on both suites:


I posted about the above to xen-users back in April 2k10.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.