[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] XCP 1.0 beta Realtek 8168 nic not working

Hi Grant:


I probably canât help much because I am Xen newbie but I am having a similar problem with the Xen 3.4.3 kernel. After googling I found this: http://elrepo.org/tiki/tiki-index.php?page=kmod-r8168 . Right now I am trying to configure the boot loader to load the new driver but I am using cobbler (also as a newbie) so things are proceeding slowly. If it works, I will let you know.






From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Grant McWilliams
Sent: Thursday, December 23, 2010 6:47 PM
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] XCP 1.0 beta Realtek 8168 nic not working


I'm trying to build out a test cloud using XCP 1.0.0 beta with 3 machines of 18 cores total (Phenom II 1090s). I've built three machines, installed XCP 1.0.0 beta on them and they all three
have the same problem - the Realtek network cards don't work. The following is the output from lspci

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

I also put in an Intel e1000 card in each box and it works. I booted off a live Ubuntu 10.04 CD and both network cards worked beautifully. I booted up on a CentOS 5.5 DVD and went into Rescue mode and both cards worked.
Is this a driver issue with XCP 1.0.0 beta?

If I plug a network cable into eth0 (the Realtek port) I get this from dmesg

r8169: eth0: link up
xenbr0: port 1(eth0) entering forwarding state

Things seem fine. Output of ethtool

[root@cloud1 ~]# ethtool eth0
Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes:  Not reported
    Advertised auto-negotiation: No
    Speed: 10Mb/s
    Duplex: Half
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: off
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
    Link detected: yes

ethtool says the device has auto-negotiate off and running half duplex. Any attempts to use ethtool to fix it fail.

So my biggest frustration is that this network card works on CentOS 5.5. The main difference between CentOS and XCP is kernel so is this a kernel issue or is there a configuration issue?

Grant McWilliams

Some people, when confronted with a problem, think "I know, I'll use Windows."
Now they have two problems.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.