[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Can't get Dom0 PV_OPS working properly

  • To: Ian Murray <murrayie@xxxxxxxxxxx>
  • From: Sergey Tovpeko <tsv.devel@xxxxxxxxx>
  • Date: Thu, 13 Jan 2011 16:14:27 +0300
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Thu, 13 Jan 2011 05:21:47 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:user-agent:mime-version:to:cc:subject :references:in-reply-to:content-type:content-transfer-encoding; b=v1mFR3/EuLwKgB0iNtAt1BbHlF4VIfNNe6fxuoZeE7qsoqMImoSkTkHFh2XdnMw2y7 NhQwe66QKanKEIFFfIcORJgE6EUehIyso/A3NwyPgKBElYvp8EHYGT7ZCRljOTvjvyz5 TygjUiy91E/05zWq8dMG3RcaHM5agW2+aOcRU=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I had a reliable system running Xen 3.4.3 (GitCo) using the CentOS Xen kernel (5.5). I wanted to do some PCI passthrough but I got an issue with MMIO (or similar). Google told me that that I had to use the Xen 2.6.18 or PV_Ops kernel. I downloaded the "Jeremy" PV_OPS kernel and compiled it okay, having followed the Wiki entry instructions (I think!). I read somewhere that I should go to 4.0.1 Xen, which I did. The kernel runs fine as a standalone kernel
and boots under Xen.

I am having the the following issues:-

* I can't get any screen console output (despite console=hvc0 at the dom0 kernel

* PV VM's fail to start properly. As soon as they start, they sit at 100% CPU according to xm top and don't progress. A Windows HVM guest appears to start okay. I haven't tried any other HVM. I have tried PV guests based on CentOS kernel and Ubuntu 10.10 PV_OPS, which do the same.

I tried to look at the various logs but I don't see anything that gives me a clue, but I am not Xen expert to know what I am looking for.

When I revert back to 4.0.1 + CentOS's Xen kernel as Dom0, all VM's start and operate properly.

Any advice is much appreciated.

Thanks in advance,

Hello, Ian!

As I understood correctly your main point is to have the ability to use PCI passthrogh.

It appears to be a problem in Jeremy's pv_ops kernel as Dom0 to run PV domains. I could propose you to try 2.6.18 Dom0 if it only suits for you.


To download it you can use Mercurial tool with
hg clone http://xenbits.xensource.com/linux-2.6.18-xen.hg

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.